This is the mail archive of the cygwin@cygwin.com mailing list for the Cygwin project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Problem with ssh/pvm/winXp


Hi folks!!!!

Im trying to use pvm over cygwin, and im not sure about what is
happening.
The thing is that i am using ssh instead of rsh. Well, no big deal...
So far, look what it happens, if trying to add some hosts using pvms
console:


----------------------->
pcosta@pcdep06 ~
$ pvm
pvm> add pcdep49
add pcdep49
0 successful
                    HOST     DTID
                 pcdep49 Can't start pvmd

Auto-Diagnosing Failed Hosts...
pcdep49...
Verifying Local Path to "rsh"...
Rsh found in /usr/bin/ssh.exe - O.K.
Testing Rsh/Rhosts Access to Host "pcdep49"...
Rsh/Rhosts Access is O.K.
Checking O.S. Type (Unix test) on Host "pcdep49"...
Host pcdep49 is Unix-based.
Checking $PVM_ROOT on Host "pcdep49"...

The value of the $PVM_ROOT environment
variable on pcdep49 is invalid ("").
Use the absolute path to the pvm3/ directory.

<-----------------------

Moreover, look at these output:

----------------------->
pcosta@pcdep06 ~
$ ssh pcdep49 "export"
declare -x ALLUSERSPROFILE="C:\\Documents and Settings\\All Users"
declare -x CMG_HOME="C:\\Arquivos de programas\\CMG"
declare -x COMMONPROGRAMFILES="C:\\Arquivos de programas\\Arquivos comuns"
declare -x COMPUTERNAME="PCDEP49"
declare -x COMSPEC="C:\\WINNT\\system32\\cmd.exe"
declare -x CYGWIN="ntsec tty"
declare -x CYGWIN32="ntsec tty"
declare -x HOME="/home/pcosta"
declare -x HOMEDRIVE="c:"
declare -x HOMEPATH="\\Cygwin\\home\\pcosta"
declare -x LOGNAME="pcosta"
declare -x LOGONSERVER="\\\\PCDEP49"
declare -x LSFORCEHOST="pcdep64"
declare -x MAIL="/var/spool/mail/pcosta"
declare -x NUMBER_OF_PROCESSORS="1"
declare -x OLDPWD
declare -x OS="Windows_NT"
declare -x OS2LIBPATH="C:\\WINNT\\system32\\os2\\dll;"
declare -x
PATH="/cygdrive/c/WINNT/system32:/cygdrive/c/WINNT:/cygdrive/c/WINNT/
System32/Wbem:/cygdrive/c/ecl/home:/cygdrive/c/ecl/macros:/usr/bin:/bin"
declare -x PATHEXT=".COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH"
declare -x PROCESSOR_ARCHITECTURE="x86"
declare -x PROCESSOR_IDENTIFIER="x86 Family 6 Model 8 Stepping 3,
GenuineIntel"
declare -x PROCESSOR_LEVEL="6"
declare -x PROCESSOR_REVISION="0803"
declare -x PROGRAMFILES="C:\\Arquivos de programas"
declare -x PWD="/home/pcosta"
declare -x SHELL="/bin/bash"
declare -x SHLVL="1"
declare -x SSH_CLIENT="143.106.81.151 3002 22"
declare -x SSH_CONNECTION="143.106.81.151 3002 143.106.81.245 22"
declare -x SYSTEMDRIVE="C:"
declare -x SYSTEMROOT="C:\\WINNT"
declare -x TEMP="/cygdrive/c/WINNT/TEMP"
declare -x TERM="cygwin"
declare -x TMP="/cygdrive/c/WINNT/TEMP"
declare -x USER="pcosta"
declare -x USERDOMAIN="PCDEP49"
declare -x USERNAME="pcosta"
declare -x WINDIR="C:\\WINNT"

<-----------------------

What am i missing here??????

It seems a problem with environmental setting, but i already define
~/.bashrc,
 ~/.profile,  ~/.ssh/environment,  ~/.ss/rc, etc....

Oh!!! Im using cygwin, pvm 3.4.3, windowsXp.......

Any help it would be great!!!!!!

Thanks in advance!!!!!

[]s
Pedraum

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]