This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: deleting a file ending with a dot

Dave Korn wrote:

-----Original Message-----
From: cygwin-owner On Behalf Of Baurjan Ismagulov

tar has created a file ending with a dot, and now I can't delete it (I've tried rm, del in cmd, explorer, far, unlink call with and without -mno-cygwin). What would you suggest before I search an 8-GB volume for the directory entry with a disk editor? I would appreciate any help (pointers to NTFS directory structure description also welcome). Scandisk didn't report any problems.

Maybe there's a problem with the perms on it? What output do you get from "ls -la file." and from "cacls file." ?

BTW, this would have been a better bug report if you had told us what actually *happened* when you tried all those things - did you get error messages? Did unlink return an error code? Or did just nothing happen? Or did your machine BSOD and start smoke pouring out the back? Knowing what happened is the first clue to start working out what went wrong, you see.

It never ceases to amaze me how people tend to forget to include such critical data. My usual response is a question: What was your first indication that it failed?
Everywhere is walking distance if you have the time.

-- Unsubscribe info: Problem reports: Documentation: FAQ:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]