This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: sshd under Cygwin

  I forgot to mention that I had to add all the editrights priveleges within
ssh-host-config to my User
account which is already a member of Administrators except for the "SeDeny*"
priveleges which I left out.
So a total of 4 priveleges were added & verbatim per the ssh-host-config

Also I discovered that I had to add the server on the command line using
single-quotes around the password because
my password had special characters in it.  The script uses double-quotes
which can cause issues depending upon the
special characters embedded.  At least this is the case if you try & use the
script cygrunsrv command line verbatim
on the shell command line.

Lastly, permissions on all the noted files/directories within
ssh_host_config/ssh_user_config are important & all
the parent directories as well.  A note about priveleges beyond the noted
directories/files through all parent directories
up to & including '/' in openssh.README & in the scripts would be a helpful

thanks & best regards,

-----Original Message-----
From: pedal2metal []
Sent: Sunday, January 02, 2005 6:45 AM
Subject: RE: sshd under Cygwin

   After using the following references:

& plenty of T&E (trial & error),
I was able to get RSA SSH2 keys to work properly.  In conclusion,
change the _user to <User Login ID> instead of 'system' in both of the above
I installed the sshd service manually but that was mainly due to
the debug/analysis nature of the work.  Shouldn't be necessary if the
_user variable is changed in both scripts.

Anyhow, this does bring up another question:
   How would one get RSA SSH2 keys to work with multiple user logins
since the cygrunsrv/sshd process can only run as 1 user?  It would
appear the answer is "Not possible" based on my T&E results.

thanks & best regards,
eric rose


-----Original Message-----
From: pedal2metal []
Sent: Sunday, January 02, 2005 1:37 AM
Subject: sshd under Cygwin

   Ok, I installed all of Cygwin & then attempted to get sshd running.  I
did this about 1.5 years ago
& it didn't seem too hard so I thought I try again.  Anyhow, this time, I've
grown a bit & use the RSA keys
of SSH Protocol 2 as my standard method so I wanted to do that this time.
   Well I ran ssh-host-config & everything looked good but only password
authentication worked.
After lots of mistakes, false starts, I figured out my /home/<UserName>
directory rights were wrong &
ran ssh-user-config to fix them which removed write priveleges for
group/world.  Still no RSA keys allowed.
Anyhow, now I'm afraid I've made a total mess of things.  I read the
/usr/share/doc/Cygwin/openssh.README file
which is how I got this email address.
I ended up trying to "reset" things.  I deleted my .ssh directory.  I
removed the "sshd" service via regedit.
I removed the "sshd" user also via Control Panel.  I then ran
ssh-user-config, regenerated my RSA SSH Protocol 2 keys, then
ran ssh-host-config & said yes to everything & I have CYGWIN='ntsec tty'.
Still no luck.  I can only connect by using my password.  I'm using the "ssh" test as my reference.
I'm guessing this whole process is a "do-once" &
once you screw it up, it can't be undone short of a complete Cygwin
re-install and/or Windows re-install, although
honestly, I have no clue.  I've done Google, read tons of emails, threads,
read the /usr/share/doc area, etc... still
no fundamental clue on the deterministic process to get RSA2 keys working
reliably with sshd under Cygwin.
I'm running Windows 2000 Pro SP4 & using a February 25,2004 archive of the
redhat mirror for the Cygwin install.

I am operational since I can use my password but I'm completely baffled by
why the RSA2 keys don't work since
I use them on my other systems which I use SSH for.

thanks & best regards,

Eric Rose

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]