This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: cannot access $HOME (on Samba) via ssh

Hash: SHA1

Corinna Vinschen wrote:
| Yes, that's Windows for you.  The interactive features don't like to
| work in pseudo ttys.  Try this:
|   net use '\\bierfass\dunkel' '/user:DOMAIN\dunkel' 'your-password'
| Assuming the name of your domain is DOMAIN.

Now _this_ worked. After that I could login via ssh
from my xterm as expected. It did not even ask for
a password this time (using .ssh/authorized_keys of
the shared directory, AFAICT).

(BTW, I don't own a real tty, but using the console
instead of a xterm to run "net use '\\bierfass\dunkel'
'/user:brauhaus\dunkel' '*'" I got system error 1326.
Still no password prompt.)

Obviously sshd had no permission to access
//bierfass/dunkel/.ssh/authorized_keys . If it had,
then it wouldn't have asked for a password.

But the error message said that //bierfass/dunkel
could not be accessed, either. The Samba log file
contained a lot of messages saying

~ guest user (from session setup) not permitted to access this share (dunkel)

So I set "guest ok = yes" in smb.conf, [home]

If I login now, then ssh still asks me for a password
(i.e. the access to //bierfass/dunkel/.ssh/authorized_keys
fails), but then I have just a read-only access to
//bierfass/dunkel. Running the verified "net use"
command you suggested I get an error message saying

- -------------------------------------------------------------
Systemfehler 1219 aufgetreten.

Die angegebenen Anmeldeinformationen stehen mit vorhandenen
Anmeldeinformationen in Konflikt.
- -------------------------------------------------------------

which might be translated as

- -------------------------------------------------------------
system error 1219 occured.

The specified logon information is in conflict to the
existing logon information.
- -------------------------------------------------------------

Any idea how to tell sshd to use my permission instead of guest to access //bierfass/dunkel?


Version: GnuPG v1.2.5 (GNU/Linux)
Comment: Using GnuPG with Thunderbird -


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]