This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Windows *.exe and stderr in xemacs shell-mode fail to appear

I don't like the Windows DOS Prompt type command window and so I use xemacs shell-mode instead. I have a Windows *.exe program that I think outputs to stderr. When I run it in a shell-mode buffer, a new DOS Window is opened and all output goes to the DOS window and not the shell-mode buffer. Anyone know how I can get the output to go to the shell-mode buffer instead?

To debug this I tried redirecting the output of the command. The redirect seems to only work in a cygwin DOS Window (C:\cygwin\cygwin.bat) but not in shell-mode. As far as I can tell, both use "bash -i" as as shell.

Here is a sample commandline:

./rave/bin/nb.exe -J-Xdebug -J-Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8765 -userdir /cygwin/home/edwingo/.Creator -J-Dtoolbox.importStartDir=/cygwin/home/edwingo/ftp -J-Drave.preview -J-Drave.project.dumpclassloader -J-Drave.projectdebug 2>&1 > ~/ide.txt

One other piece of data is that I have another *.exe which does output to the shell-mode buffer. It also opens a DOS window, but nothing appears there. This is what I want. I don't know enough about Win32 to understand why. Any ideas?


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]