This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Call for testing Cygwin snapshot (problem with inode numbers. problem figured out)

On Dec  4 11:41, Peter Rehley wrote:
> >On Dec  2 12:34, Peter Rehley wrote:
> >>On Dec 2, 2005, at 3:14 AM, Corinna Vinschen wrote:
> >>>The problem is, that your Samba version apparently screws up the  
> >>>inode
> >>>information and we have re-enabled using the inode numbers sent from
> >>>remote file systems which are supposed to be capable of that.  For
> >>>this
> >>>we use the HAS_PERSISTENT_ACLS property.
> >>>[...]
> >>I'm using mac os x 10.4.3 which is using samba version 3.0.10.  So
> >>it's not that old.  However, I did find one reference that implied
> >>that mac did something funny for acl's.
> >>
> >>I'm going to try install a non-apple version of samba and see what
> >>happens.
> >[...]
> Can I say "D'oh"?  I knew I could ;)
> The problem turned out to be a samba configuration issue.  Several  
> months ago I had added the parameter "large readwrite = no" to my  
> smb.conf file in order to speed up transfers between my mac and  
> windows.  When it's in the configuration file the inodes are messed  
> up.  When I remove it, the inodes are fine.
> I get the same behavior on a non-apple version of samba... in my case  
> I tried the darwinports version, 3.0.20b, and large readwrite had the  
> same problem.
> So problem solved.

Cool.  Thanks for keeping us informed so this is in the archives now.
Maybe that's even worth to note in the FAQ.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat, Inc.

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]