This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Rsync over SSH not working when ZoneAlarm installed

Larry Hall (Cygwin <reply-to-list-only-lh <at>> writes:

> Zarko Roganovic wrote:
> > Hello,
> > 
> > I'm trying to backup a directory from a Win 2K machine to a Linux server 
> > cmd below.
> > 
> > rsync -rvc -e "ssh -l testusr" /cygdrive/c/testdir
> > 
> > When I uninstall ZoneAlarm(6.1.737) this same command works fine.
> > It doesn't help if I shutdown ZoneAlarm, I have to uninstall it. This is a 
> > machine and I'm willing to run ANY tests that you might suggest. I've 
> > the cygcheck output with ZoneAlarm installed and when it wasn't.
> We actually ask for *attachments* of cygcheck output, not inclusions.
> > I really need this to work and I would appreciate any help.
> This sounds like a firewall configuration problem rather than a Cygwin
> software problem.  Didn't ZoneAlarm query you when you first tried the
> rsync?  I thought that was it's modus operandi.  In any case, you need
> to open port 873 for rsync to run at least.  You can check the man page
> for more info.


I apologize about pasting the cygcheck output instead of attaching it.

ZoneAlarm did ask if I'd like to let rsync access the internet and I did
say to allow it. However it never asks it ssh.exe should be allowed to
access the net. Lastly I don't think the port is the problem because
even when I shut down ZoneAlarm I get the same result. I have been
able to use rsync just by itself to sync with a rsync server with
ZoneAlarm still running.


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]