This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Rsync over SSH not working when ZoneAlarm installed

Zarko Roganovic wrote:
Larry Hall (Cygwin <reply-to-list-only-lh <at>> writes:

Zarko Roganovic wrote:


I'm trying to backup a directory from a Win 2K machine to a Linux server


cmd below.

rsync -rvc -e "ssh -l testusr" /cygdrive/c/testdir

When I uninstall ZoneAlarm(6.1.737) this same command works fine.
It doesn't help if I shutdown ZoneAlarm, I have to uninstall it. This is a


machine and I'm willing to run ANY tests that you might suggest. I've


the cygcheck output with ZoneAlarm installed and when it wasn't.

We actually ask for *attachments* of cygcheck output, not inclusions.

I really need this to work and I would appreciate any help.

This sounds like a firewall configuration problem rather than a Cygwin software problem. Didn't ZoneAlarm query you when you first tried the rsync? I thought that was it's modus operandi. In any case, you need to open port 873 for rsync to run at least. You can check the man page for more info.


I apologize about pasting the cygcheck output instead of attaching it.

ZoneAlarm did ask if I'd like to let rsync access the internet and I did
say to allow it. However it never asks it ssh.exe should be allowed to
access the net. Lastly I don't think the port is the problem because
even when I shut down ZoneAlarm I get the same result.

That turns out not to be significant.  Many firewalls install "stuff" in
the TCP stack so turning them off does not necessarily get you to the
same state as uninstalling, as you already determined for yourself.  In
other words, ZoneAlarm is getting in your way whether you're running it
or not.  You need to get ZoneAlarm configured to allow these applications
to run.  Effectively, that means opening ports the apps use.  ZoneAlarm
probably didn't ask about 'ssh' because it couldn't "see" it buried within

I have been
able to use rsync just by itself to sync with a rsync server with
ZoneAlarm still running.

Well, if you can use 'rsync' with ZoneAlarm after telling it to permit
'rsync' access then you should find you have luck when you do the same
for 'ssh'.  Try running 'ssh -l testusr' and see what
ZoneAlarm has to say.  I bet that will trip it and you'll find you
can get access with both 'ssh' and 'rsync', separately or together.
If not, you'll need to configure port 22 to be open for 'ssh'.

I feel compelled to point out that this is really a firewall configuration
issue and as such, it's really not on-topic for this list.  If the above
information isn't enough to get this problem resolved to your satisfaction,
you should really look for some specific help with configuring ZoneAlarm.
Much discussion of ZoneAlarm's workings isn't really appropriate here.

Larry Hall                    
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
838 Washington Street                   (508) 893-9889 - FAX
Holliston, MA 01746

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]