This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: SSH problem after upgrade - SOLVED

On Fri, 23 Dec 2005, Ed Brady wrote:

> Ed Brady wrote:
> > Igor Pechtchanski wrote:
> > > IIRC, the Windows dynamic loader will first look for DLLs in the
> > > application directory, and only then in the PATH.  Here's a WAG: do you
> > > have a copy of winsock.dll or ws2_32.dll in /usr/bin?
> The problem is now solved.
> The culprit is due to the installation of the cmake-2.2.3-1 package.
> (Located in development).  This package, copies three Microsoft Windows
> specific dll's to /usr/bin.  Specifically, mfc71.dll, msvcp71.dll, and
> msvcr71.dll.  Once I uninstalled this package ssh, telnet, and ftp,
> worked as intended.
> As a sanity check, I unzipped the package and manually copied the dlls
> to /usr/bin and the problem returned.
> Igor P., it looks like your WAG pretty much nailed it.
> Thanks to all who had input

Glad I could help.  I also see that cmake-2.2.3-1 was removed from the
distribution pending a fix for this.
      |\      _,,,---,,_
ZZZzz /,`.-'`'    -.  ;-;;,_
     |,4-  ) )-,_. ,\ (  `'-'		Igor Peshansky, Ph.D. (name changed!)
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"Las! je suis sot... -Mais non, tu ne l'es pas, puisque tu t'en rends compte."
"But no -- you are no fool; you call yourself a fool, there's proof enough in
that!" -- Rostand, "Cyrano de Bergerac"

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]