This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: 2.510.2.2: bash won't open after install

First, let me say "Thank you" for taking some time to help me with
this problem.  It has been a most frustrating issue for me.  I have
done as you suggested and the results are listed out below.

On 12/28/05, René Berber <> wrote:
> Nick Low wrote:
> > Alright, I put in the pause at the end of the batch file like you
> > suggested, and now the window opens and displays the following
> > message:  "Press any key to continue..."  Of course, pressing any key
> > closes the window.
> >
> > There is no other information displayed in the window.
> OK, if you want more output change the first line to "@echo on", and while you
> are there why not put "--verbose --debug" parameters to bash.

Turning on the echo does not yield any useful information in the
command window.  I can now see the commands that are called by the
batch file, but there is no information displayed between the line
that now reads "bash --login -i --verbose --debug" and "pause".  I
also tried just "bash --verbose --debug" and that yielded no
information either.

> > I tried out the following command from a cmd window:
> >
> > strace bash --login -i > nick.out
> >
> > This command yielded a command prompt.  When I doubled clicked on the
> > shortcut located on my desktop, I was able to use Cygwin normally in
> > that window.  I typed set at the prompt and can see that the HOME
> > value is set to /home/Administrator.  I am able to cd to that
> > directory from the Cygwin window without any problems.
> Change to $HOME?  it should have started on $HOME, was it somewhere else?

I changed to $HOME and it put me in the /home/administrator folder. 
When I logged in, it did place me in that directory to start with as

> > I can close out the window in which I was running the strace, and the
> > Cygwin window that I started up while it was running works fine.  If I
> > open up another Cygwin window while the second window is open (and now
> > the first window with the strace running in it is closed), that works
> > fine as well.  If I close all of the Cygwin windows though, and then
> > try to open up a new window, I am back to square one - "Press any key
> > to continue..."
> Never seen something like that.
> > Any other ideas out there?
> Only questions: your cygcheck output said the PC has 4 processors, is it 2 with
> hyper-threading or really 4?  Some people have reported unusual errors with
> hyper-threaded CPUs, most problems where solved some time ago but you should
> search the list just to make sure.

It is really two CPUs with Hyperthreading.  I am reading through the
archives now to see if there is anything useful in them, but so far I
have not come up with anything.

> Perhaps you can get out something interesting with the --debug parameter to bash.

Running in the verbose/debug mode displayed the .profile and .bashrc
information as it was run.  However, I only saw that after I had
started up a second bash session (after having started a first bash
session using strace).

I have several other servers running Cygwin that are just fine.  I ran
the strace command on one of them and started comparing the output
from a working system to that of the broken system.  The difference
that I came across is that the broken system displays the following
sequece of events (this is repeated for values (3) --> (19))

280   49084 [main] bash 7864 close: close (3)
115   49199 [main] bash 7864 __set_errno:
cygheap_fdget::cygheap_fdget(int, bool, bool):387 val 9
94   49293 [main] bash 7864 close: -1 = close (3)

On the functional system, the middle line containing the cygheap_fdget
error does appear.  All that I see on that system are the close
messages.  I searched for information on cygheap_fdget and found no
information that I could make use of.

As you can imagine, the output files are quite large (over 10 MB), so
it is going to take some time to go through them.  If I can find
anything in the logs that might be meaningful, I shall post it.


> --
> René Berber
> --
> Unsubscribe info:
> Problem reports:
> Documentation:
> FAQ:         

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]