This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Help:Can not edit crontab becuase of vi not found

From: Brian Dessent <>
Subject: Re: Help:Can not edit crontab becuase of vi not found
Date: Thu, 29 Dec 2005 12:05:53 -0800

lin q wrote:

> I wonder what the problem is, I can start vi by running, /usr/bin/vi.

What does "ls -l /usr/bin/vi" report?  And your cygcheck output would
have been helpful.
All right, you hit it right on.

"ls -l /usr/bin/vi" says 'ls: File or directory "/usr/bin/vi" is not found'. I am confused...because
1) I can run "/usr/bin/vi"
2) If I "cd /usr/bin" and then "ls vi", it is there

I check the mount point, c:/cygwin/bin is mounted to /usr/bin, and both c:/cygwin/bin and /usr/bin are in $PATH.

I am totally lost, what could be wrong?

You mentioned runing cygcheck, I did that, "cygcheck -sv /usr/bin/vi", it returns "C:/cygwin/bin/vi - os=45841.30695 img=60008.34 sys=46070.30695" and a lot of other system information.

I am not sure what I am supposed to check, could you elaborate on that?

> I also tried "export EDITRO=/usr/bin/vi" and "export EDITOR=/usr/bin/vim",
> neither one works.

I think it uses VISUAL. Check the manpage of crontab.
I run "man crontab", it says manpage is not installed. Is VISUAL a program?


FREE pop-up blocking with the new MSN Toolbar ? get it now!

-- Unsubscribe info: Problem reports: Documentation: FAQ:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]