This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

ssh configuration

I'm trying to set up ssh (ie. openssh) on cygwin, with not much success.
 Searching the mailing list did not help either.

I've downloaded it, installed it, run ssh-host-config, answered all yes.
I *CAN* ssh from windows to a linux box in my lan.
But, my windows box fails as a ssh server.
Not even ssh localhost works.

Here's the full info:

> /usr/sbin/sshd.exe -d -d -d -D
debug2: load_server_config: filename /etc/sshd_config
debug2: load_server_config: done config len = 196
debug2: parse_server_config: config /etc/sshd_config len 196
debug3: /etc/sshd_config:13 setting Port 22
debug3: /etc/sshd_config:38 setting StrictModes no
debug3: /etc/sshd_config:92 setting UsePrivilegeSeparation yes
debug3: /etc/sshd_config:106 setting Subsystem sftp
debug1: sshd version OpenSSH_4.6p1
debug1: private host key: #0 type 0 RSA1
debug3: Not a RSA1 key file /etc/ssh_host_rsa_key.
debug1: read PEM private key done: type RSA
debug1: private host key: #1 type 1 RSA
debug3: Not a RSA1 key file /etc/ssh_host_dsa_key.
debug1: read PEM private key done: type DSA
debug1: private host key: #2 type 2 DSA
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-d'
debug1: rexec_argv[2]='-d'
debug1: rexec_argv[3]='-d'
debug1: rexec_argv[4]='-d'
debug1: rexec_argv[5]='-d'
debug1: rexec_argv[6]='-D'
debug2: fd 3 setting O_NONBLOCK
debug1: Bind to port 22 on
Server listening on port 22.
Generating 768 bit RSA key.
RSA key generation complete.
debug1: fd 4 clearing O_NONBLOCK
debug1: Server will not fork when running in debugging mode.
debug3: send_rexec_state: entering fd = 7 config len 196
debug3: ssh_msg_send: type 0
debug3: send_rexec_state: done
debug1: rexec start in 4 out 4 newsock 4 pipe -1 sock 7

> ssh -v -v -v localhost
OpenSSH_2.9p2, SSH protocols 1.5/2.0, OpenSSL 0x0090602f
debug1: Seeding random number generator
debug1: Rhosts Authentication disabled, originating port will not be
debug1: restore_uid
debug1: ssh_connect: getuid 500 geteuid 500 anon 1
debug1: Connecting to localhost [] port 22.
debug1: temporarily_use_uid: 500/544 (e=500)
debug1: restore_uid
debug1: temporarily_use_uid: 500/544 (e=500)
debug1: restore_uid
debug1: Connection established.
debug1: identity file /z/.ssh/identity type -1
debug1: identity file /z/.ssh/id_rsa type -1
debug1: identity file /z/.ssh/id_dsa type -1
ssh_exchange_identification: read: Connection reset by peer
debug1: Calling cleanup 0x41bcc4(0x0)


I also tried running ssh-user-config and created all authentications,
with my password as pass phrase.  Still no go.  And when doing that, ssh
complains that all the files are invalid, with tons of errors, which
from other emails I've gathered as "normal".


More info:
- cygwin is installed on a FAT partition of a WinXP (SP1) box, with
latest patches.
- Windows is a Spanish version of it.
- I have at least one user without a password.  I've also gone and
modified the ssh configuration file to add in sshd_config:
     PermitEmptyPasswords no
- I've synced passwd and groups with mkpasswd -l and mkgroup -l.
- I'm running under a firewall (not the XP one), but I've switched it off.

Can anyone help?

Gonzalo Garramuño

AMD4400 - ASUS48N-E
Kubuntu Edgy

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]