This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: run-time problems with cygwin-1.5.24-2

Todd Brunhoff schrieb:
Problem: after installing cygwin-1.5.24-2, most things work but I've noticed a few things that don't work: perl and subversion (svn). Specifically, the programs do absolutely nothing... command line arguments are ignored, there is no output, and the commands appear to do nothing. There are no error messages, no entries in the event log, etc.

Detailed background:
I have used a cygwin for about 8-9 years for bridge development between linux and windows. I currently run 1.5.14 and have used it consistently for a year or more. I loaded 1.5.24-2 from three different sites, all with the same result, the latest being In an effort to identify the installation problem, I simplified the installation to: default install for everything, then force install for development, system and vim. The installation runs fine, completes, and bash and my .bashrc and vim and a variety of things work. Perl does nothing and svn does nothing.

In an effort to see what the problem might be, I focussed on perl (although interesting, this info may not be helpful):
- I loaded source for perl 5.8.8, ran Configure, but the compile fails because of conflicting vsprintf declarations.

If you follow the directions of the README and download the src package you would be able to build your perl.
A Policy file helps and the correct Configure line is required.

- I loaded source for perl 5.6.2, ran Configure, with a few less errors, but still failure in the compile. I fixed the compile by modifying config.h (to say that I had vsprintf, which indeed the environment does), and the compile works, but the make fails later with an unsupported call to opendir.
- I switched back to cygwin 1.5.14, and for grins, tried the build for both perl 5.8.8 and 5.6.2... both worked fine.

Perhaps the cygwin dll is in transition... Please help.

An error report would be nice. See
"Run cygcheck -s -v -r > cygcheck.out and include that file as an attachment in your report. Please do not compress or otherwise encode the output. Just attach it as a straight text file so that it can be easily viewed."

Running cygcheck /bin/perl usually finds the culprit.

I had this symptom "perl doing nothing" with an empty PATH. Or /bin not in the PATH.
Reini Urban

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]