This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

ssh ProxyCommand not finding anything to execute

Hi All
I am trying to connect to my home computer from work and I have to use the
work HTTP proxy on port 443 in order to do so.  I have done this using PuTTY
just fine so I know there is nothing wrong with my setup.  I have downloaded
the windows binary of Connect and placed it in the same folder as the ssh
binary (c:\cwrsync\bin).  If I try to run the connect command by itself in
debug mode I can connect to the proxy and thus my home PC just fine:

bash-3.00$ connect -d -H proxy:8085 myhomepc 443
DEBUG: No direct address are specified.
DEBUG: relay_method = HTTP (3)
DEBUG: relay_host=proxy
DEBUG: relay_port=8085
DEBUG: relay_user=myuser
DEBUG: local_type=stdio
DEBUG: dest_host=myhomepc 
DEBUG: dest_port=443
DEBUG: Program is $Revision: 100 $
DEBUG: checking myhomepc is for direct?
DEBUG: myhomepc for not direct.
DEBUG: resolving host by name: proxy
DEBUG: resolved: proxy (
DEBUG: connecting to
DEBUG: begin_http_relay()
DEBUG: >>> "CONNECT myhomepc:443 HTTP/1.0\r\n"
DEBUG: >>> "\r\n"
DEBUG: <<< "HTTP/1.0 200 Connection established\r\n"
DEBUG: connected, start user session.
DEBUG: <<< "\r\n"
DEBUG: connected
DEBUG: start relaying.
DEBUG: recv 31 bytes
SSH-2.0-OpenSSH_4.3p2 Debian-9

DEBUG: sent 2 bytes
DEBUG: recv 19 bytes
Protocol mismatch.
DEBUG: connection closed by peer
DEBUG: relaying done.
DEBUG: that's all, bye.

I have installed cwRsync which has the OpenSSH client version 4.5.  I should
be able to type in the following:

ssh -v -o ProxyCommand="connect -H -d proxy:8085 %h 443" user@myhomepc

However I get the following error:

OpenSSH_4.5p1, OpenSSL 0.9.8d 28 Sep 2006
debug1: Executing proxy command: exec connect.exe -H proxy:8085 myhomepc 443
debug1: permanently_drop_suid: 400
/bin/sh: No such file or directory
debug1: identity file /cygdrive/c/Documents and
Settings/myuser/.ssh/identity type -1
debug1: identity file /cygdrive/c/Documents and Settings/myuser/.ssh/id_rsa
type 1
debug1: identity file /cygdrive/c/Documents and Settings/myuser/.ssh/id_dsa
type -1
ssh_exchange_identification: Connection closed by remote host

The problem is that it doesn't seem to be finding the connect binary.  If I
remove all the "connect.exe...." stuff and just leave it as "" or put random
stuff in there, I get exactly the same error.  C:\cwRsync\bin is in my PATH
variable so I can type it from anywhere.
I have tried specifying the location with:
and I have tried copying the binary to various places on my hard drive to no

My understanding is that I should get some output from Connect once it finds
it as I have specified the -d flag.
What am I doing wrong?
View this message in context:
Sent from the Cygwin Users mailing list archive at

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]