This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

OpenSSH and user environment: Maybe not initialized correctly


I am experiencing some trouble with OpenSSH under Cygwin.
Details on my Cygwin installation can be found in the attached
outputs of "cygcheck -s -v -r > cygcheck.out" on the
machines in the zipped attachment.
[I tried to send with attachment, but obviously it did not get
through your protection mechanisms... Now trying without attachment...]

 SERVERs     amd64      and     smithfield
 CLIENT       fi-win
The username on all machines is "illenseer" and public key authentication
is set up and working fine on all machines. The sshd was setup on the
SERVER machines using "ssh-host-config" with privilege separation.
  MACHINE AMD64:     Windows Server 2003 64bit
  MACHINE smithfield:  Windws XP SP 2 32bit

The main problem is that obviously the processes started by SSH on
a remote machine are not always executed in a proper environment.
Namely I am trying to launch a parallel MPI program using MPICH2
on a remote machine via a SSH connection. The MPICH2 then
does not recognize the user correctly and cannot start with the
encrypted user and password. But this is only the "story" for my
issue... I then tested and tried some other very simple command:

   ssh amd64 whoami
   ssh smithfield whoami

which then also does not print the expected result on all machines!
I am expecting "illenseer", but on amd64 it was "sshd_server"
(whereas on the 32bit smithfield machine it was "illenseer" correctly).

I think this is also a main reason for the failing of my MPI program,
because MPICH2 also uses some machanism (Win32 API) to determine the
current user... and thus this might also fail for the same reasons as
the "whoami" program, because I am always presented "sshd_server"
as default user from MPICH2.

Can anyone clarify or provide some help or suggestions on how to get
this working correctly on all machines?

Thanks in advance. Frank

-- Unsubscribe info: Problem reports: Documentation: FAQ:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]