This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Memory leak problem reported with gfortran

Jerry DeLisle wrote:
I have confirmed this problem on Cygwin reported here:

I am not very familiar with the windows environment. Having patched most of the gfortran I/O library in the last 2-3 years I can say that we do a lot of memory allocation for I/O.

On Linux based systems we do not see any issues (checked with valgrind). This problem acts like a failure to free memory. I do not know what is meant by the term "handle" other than a pointer to an allocated block of memory.

Those of you most familiar with the Windows environment could perhaps help here. Is this a bug in Cygwin memory management?

I will be happy to provide additional information as soon as I know what is pertinent.

I have latest Cygwin as of about two weeks ago and I can provide a gfortran binary if needed.
I wouldn't be surprised if each cygwin installation acted somewhat differently. On my Core 2 Duo laptop, if I run from the bash prompt, it hangs after the first prompt. If I run under gdb, it exhibits no problem. If there's any interest, I'll try the Pentium D tomorrow.

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]