This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [1.5.25-7] bash: fork Permission denied

Jamil Ben Alluch wrote:
I have been trying to install cygwin for the last couple of days with no success.
I have installed the very basic stuff (Base + whatever else is required for a working installation).
Once setup finishes I launch Cygwin; this is the output I get:

Copying skeleton files.
These files are for the user to personalise
their cygwin experience.

These will never be overwritten.

    10 [main] bash 672 fork: child -1 - CreateProcessA failed, errno 13
bash: fork: Permission denied
bash-3.2$ ./.bash_profile
bash-3.2$ ./.inputrc
./.inputrc: line 17: \e[3~:: command not found
./.inputrc: line 20: \e[1~:: command not found
./.inputrc: line 21: \e[4~:: command not found
./.inputrc: line 24: \e[H:: command not found
./.inputrc: line 25: \e[F:: command not found
./.inputrc: line 28: \e[7~:: command not found
./.inputrc: line 29: \e[8~:: command not found
./.inputrc: line 32: \eOH:: command not found
./.inputrc: line 33: \eOF:: command not found
bash-3.2$ exit
    10 [main] bash 4212 fork: child -1 - CreateProcessA failed, errno 13
bash: fork: Permission denied

It's worth checking your whole system for cygwin1.dll. If there's more than the one you just installed, that's the problem. Get rid of others. My guess is that if this is the problem, you have <> software installed that's running its stuff. You'll have to kill that before you can get rid of the other cygwin1.dll(s).

The other alternative is that you have <>.

If one or the other of these hits the mark, you should be able to rerun
"setup.exe" and just click through all the screens.  "setup.exe" should
run all your postinstall scripts and set things up properly.  If not, I
guess you're stuck starting over again, though it sounds like you don't
have much invested yet so that's probably not a painful process.

I've tried to install in other directories with no success.
I had a working installation of cygwin before and tried reinstalling it after it stopped working for a reason that is still unknown to me (I suspect windows update, but I'm not sure...)

Could it have been around the time you installed Interix/SFU?

Any help appreciated.



Here is my cygcheck output:

We like this attached instead of appended.


Larry Hall                    
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
216 Dalton Rd.                          (508) 893-9889 - FAX
Holliston, MA 01746


A: Yes.
> Q: Are you sure?
>> A: Because it reverses the logical flow of conversation.
>>> Q: Why is top posting annoying in email?

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]