This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Cygwin Postinstall Scripts Failure [Repost without disclaimer]

[My apologies for the repost, but I had mistakenly allowed our
mailer to put a disclaimer on the 1st post.  However, note that
the text below was updated to indicate that this works for
32-bit Win2003 under Xen.  Please see the original note for
a disclaimer that made it through the filters, as the note
did make it into the archives.]


I tried to do a new cygwin install on Windows 2003 Server (x64).
This is probably about the 30th time I’ve installed cygwin in the
last couple of years, but it might be the first 64-bit 2003
install I’ve done (I have successfully done 64-bit Vista installs
a few months ago).

Note that the install appears to succeed from the point of view of
running the setup.exe command.  But when I bring up the first bash
shell, the PATH does not include /bin or /usr/bin.  I traced this
back to /etc/profile not existing and this ultimately lead me to
postinstall script failures.

I’ve attached the setup output showing that most of the postinstall
scripts fail with either an error or 126 or 128.  I’m still unsure
what these error codes are exactly so any pointers to the meaning
of these would be appreciated.  Note that the setup.log.full was
edited down as it the full version was rejected by a mail gateway.
Let me know if I editing out anything you wish to see.

More details on the scenario are:

1. The install was on a Xen virtual machine
2. Windows was installed and all updates applies immediately before
   installing cygwin
3. This was Windows 2003 R2 (but not with SP2)
4. The setup.exe came from the webpage on April 29, 2008
5. The dotsrc mirror was used
6. The on change to the default package selection was to include "vim"
7. The install was done from the local "Administrator" account
8. The box was not in a domain
9. While the above refers to the single run where I attempted this,
   I have run into this problem during multiple tries in the last
   few days, but I'm hoping this example is has fewer variables
   than the previous run (which was not on a newly installed Windows
   box that had been up an running for a while in a Xen VM)

Any suggestions on further experiments/diagnosis I can do would be
welcome. I have tried this with 32-bit Win2003 and that worked ok,
or at least well enough.  I still got failures in postinstall but
only for and which reported the sane
126 error code with "/bin/sh: bad interpreter".  But, from what I see,
these failures are not a serious problem, things seem to work fine
from my point-of-view.

Also, I tried running the /etc/postinstall scripts by-hand after
the install completed.  I didn't see any errors reported from
this, but it didn't appear to fix the problem (e.g., /etc/profile
still did not exist).

-- Eric

Be a better friend, newshound, and 
know-it-all with Yahoo! Mobile.  Try it now.;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ

Attachment: cygcheck.out
Description: Binary data

Attachment: setup.log
Description: Binary data

Attachment: setup.log.full.edited
Description: Binary data

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]