This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: CreateProcessA failed, errno 11 [BLODA alert]

On 5/1/2008 1:57 PM, Thomas Plank wrote:
David Rothenberger wrote:

On 5/1/2008 1:17 PM, Thomas Plank wrote:

I have NO kind of the mentioned "BLODA" software installed on my system
and my cygwin installation worked now for nearly 4 years.
(Windows XP SP2, all security updates)

I had the same issue and just tracked it down to the ATI Catalyst 8.3
and 8.4 drivers. I had no problem with the 7.10 version, but with both
8.3 and 8.4, my PIDs were never reused and doing a large compile (in my
case, subversion) would cause the error you mentioned.

Strange! I have an ATI graphic card in my system and I had installed both 8.3 and 8.4. But not the Catalyst Control Center, just the display drivers. For now, 8.4 is installed.

I uninstalled the drivers and installed the drivers from Windows Update
(version 8.421.0.0). I'm not sure if it's the Catalyst Control Center or
some other part of the 8.4 full driver package, but this solved my problem.

To clarify, I uninstalled all the ATI drivers using their uninstall utility. Then, I installed just the WDM Integrated Drivers from the ATI driver package. After the reboot, Windows said a new piece of hardware was detected. I let it search for drivers and it downloaded them from Windows Update. I'm not really sure what installing the WDM Integration Drivers did. But, I did not install the ATI Display Drivers or the CCC.

So you are not experiencing any fork() problems any longer? Really
strange. What kind of sh*** the ATI drivers must be ...

Nope. I could easily reproduce the problem by building subversion 1.5.0-rc4. My PIDs would get up into the 300,000s and everything would eventually die with fork errors. Other applications on the system would also encounter problems. Stopping all Cygwin processes did not solve the problem; only a reboot did. After uninstalling Cat8.4, I successfully built subversion and the tests have been running for a few hours. Max PID on my system is 6032 and page file usage is stable.

Also the time window seems appropriate. 8.3 was released in March I think
and that is around the same time when I payed attention to the error the first

Perhaps another BLODA? :-(

Really seems so. :-(


David Rothenberger  ----

system-independent, adj.:
        Works equally poorly on all systems.

-- Unsubscribe info: Problem reports: Documentation: FAQ:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]