This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: svn / subversion does not print

gds wrote:
David Rothenberger wrote:
On 5/12/2008 12:32 PM, gds wrote:
No svn commands print, e.g., "svn help" comes up blank with no errors printed. This happened before and I wrote down in notebook "svn needs crypto pkg to run...". However, did not write down which "crypto" package. Installing the "crypt" cygwin package did not help.

This only started after a cygwin upgrade and reboot. Before that it worked fine. Any ideas what I need to do?

My WAG is that you're missing a DLL. Try running "cygcheck `which svn`" and look for messages about missing DLLs. If you find any, please report back to the list so the setup.hint can be fixed.

Yes, strace and cygcheck both indicate that cygexpat-0.dll is missing and should be in /bin. Don't see it there. Just see an "expat" package in the installer, no libexpat0 as pointed out here:

Sounds like there is a packaging problem.

Tried going back to svn 1.4.5-1 instead of latest 1.4.5-2 with same result.

I was wrong, there is a libexpat0 (I was looking for "libxpat0"). Re-installing
it seems to fix the problem.

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]