This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: rxvt in native mode, widely spaced characters [Was: Re: why "Sorry, your message has been denied due to keywords found in your subject"?]

Charles Wilson wrote:
Daniel Barclay wrote:
However, I suggest rather than blindly re-installing/un-installing packages at random

Hey, I wasn't randomly installing and uninstalling packages. My setup was seemingly working fine until I installed some unrelated package (Ruby) and then rxvt changed behavior. Something in the overall installation (running CygWin.exe) broke my rxvt setup. That sounds like something is wrong in selected-package management in CygWin.exe (most likely its user interface (i.e., not making it clear what is happening)). [Now that I see your hyphothesis below: Okay, it's probably not the type of UI problem I thought (unclear package selection implications), but now I wonder if it displays post-install script messages.]

, you instead read the documentation.


Where's the documentation on CygWin.exe and things such as whether it remembers
previous selections (no, right?), and how to add a package without touching
anything else (except also installing what it depends on, of course).

Just now, I tried installing the ruby package, and as soon as I started rxvt,
it started in messed-up form--widely spaced characters, in yellow, on a dark
blue background--rather than the way it started immediately before--normally
spaced characters, in black, on a white background.

"before" == default when rxvt can't find, and is not explicitly given, any configuration information at all.
> "after" == rxvt found the default system app-defaults file
> (/etc/X11/app-defaults/Rxvt) but you do not have the fonts that it
> specifies.
Does that color change give any hints regarding what's happening (what
unrelated thing got modified when I re-ran cygwin.exe to install Ruby)?

My guess is that rxvt's own postinstall script, which is supposed to copy /etc/defaults/etc/X11/app-defaults/Rxvt into the actual /etc/X11/app-defaults/ directory failed the first time you ran setup. Then second time you ran setup, it tried again to run all the post-install scripts that had not yet succeeded. This second time, it worked, and you are now the proud owner of an /etc/X11/app-defaults/Rxvt file, which rxvt.exe now finds.

Ah, okay, that sounds like a good theory. I'll see if I can confirm that that's what's happening.

Change the two lines that start with Rxvt*font and Rxvt*boldfont in /etc/X11/app-defaults/Rxvt with the following ...

Is there a non-X11 command to list names of and show samples of the available fonts? (Or do I need to run X11 to do that?)

Thanks for cutting through the confusion caused by the other misleading answers I got--and especially for explaining the core of what is or might be happening, rather that just saying to install fonts.



Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]