This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: Recently installed cygwin - cannot install gcc

Reini Urban wrote on 13 May 2008 18:34:

> 2008/5/13 David Ziants <dziants@013>:
>> Installed cygwin under Windows XP prof, and the basic environment works.
>> I cannot do gcc nor can I find reference to the compiler under any of
>> the bin directories. 
>>  Have run the setup a second time (as advised by documentation) and also
>> tried reinstalling from a different mirror. Explicitly tried to
>> install/reinstall the "develop" package where gcc is supposed to be
>> installable from.
> install gcc-core and not gcc.

  If you're going to do that, you will have to manually install the C++
packages that gcc would pull in that gcc-core doesn't: "gcc-g++
gcc-mingw-g++".  (Assuming you want C++, of course, but most folks do....)

> gcc has an invalid tar for me also.

  Setup.exe version numbers involved?  There have been some issues there
lately to do with how we define an "empty" tarball[*], but:

/artimi/software/firmware $ wget
           => `gcc-3.4.4-3.tar.bz2'
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 46 [application/x-tar]

100%[====================================>] 46            --.--K/s

18:50:43 (485.02 KB/s) - `gcc-3.4.4-3.tar.bz2' saved [46/46]

@_______. .
(       /"\
 '"  '"'---'
/artimi/software/firmware $ tar tvfj gcc-3.4.4-3.tar.bz2  && echo OK
@_______. .
(       /"\
 '"  '"'---'
/artimi/software/firmware $


[*] - See and
subsequent thread for info.
Can't think of a witty .sigline today....

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]