This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

1.5.25-11: Bash Fails after initial install on Windows 2008 Server

Please let me know if you have any suggestions on how I can
debug the following problem in more detail.

I installed cygwin today on a Windows 2008 (32-bit) server
and bash appears to fail with the following stackdump when
run.  I tried various options (such as "bash --version" which
I expected to be quite minimal) and it still failed.

The install was on a system where cygwin was not installed
(but I had tried many previous times but had (hopefully!)
fully removed the remnants of those installs).

I did not add or remove any additional packages to/from the
installation, but simply took the default set of packages.

This failure results in most if not all of the postinstall
scripts failing.

Here's an example of trying to run bash from a Windows cmd shell:

C:\cygwin\bin>bash --version
      3 [main] bash 3000 _cygtls::handle_exceptions: Exception: STATUS_ACCESS_VIOLATION
    813 [main] bash 3000 open_stackdumpfile: Dumping stack trace to bash.exe.stackdump
 495959 [main] bash 3000 _cygtls::handle_exceptions: Exception: STATUS_ACCESS_VIOLATION
 513048 [main] bash 3000 _cygtls::handle_exceptions: Error while dumping state (probably corrupted stack)

The cygcheck output is included below.




Cygwin Configuration Diagnostics
Current System Time: Tue May 20 11:31:56 2008

Windows Longhorn/Vista (not yet supported!) Ver 6.0 Build 6001 Service Pack 1

Running in Terminal Service session

Path:   C:\Windows\system32

Output from C:\cygwin\bin\id.exe (nontsec)
UID: 400(Administrator) GID: 401(mkpasswd)

Output from C:\cygwin\bin\id.exe (ntsec)
UID: 400(Administrator) GID: 401(mkpasswd)

SysDir: C:\Windows\system32
WinDir: C:\Users\Administrator\WINDOWS

Path = 'C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem'

APPDATA = 'C:\Users\Administrator\AppData\Roaming'
CommonProgramFiles = 'C:\Program Files\Common Files'
ComSpec = 'C:\Windows\system32\cmd.exe'
HOMEPATH = '\Users\Administrator'
LOCALAPPDATA = 'C:\Users\Administrator\AppData\Local'
OS = 'Windows_NT'
PROCESSOR_IDENTIFIER = 'x86 Family 15 Model 67 Stepping 2, AuthenticAMD'
ProgramData = 'C:\ProgramData'
ProgramFiles = 'C:\Program Files'
PUBLIC = 'C:\Users\Public'
SystemDrive = 'C:'
SystemRoot = 'C:\Windows'
TEMP = 'C:\Users\ADMINI~1\AppData\Local\Temp\2'
TMP = 'C:\Users\ADMINI~1\AppData\Local\Temp\2'
USERNAME = 'Administrator'
USERPROFILE = 'C:\Users\Administrator'
windir = 'C:\Windows'

HKEY_CURRENT_USER\Software\Cygnus Solutions
HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin
HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\mounts v2
HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\Program Options
HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions\Cygwin\mounts v2
  (default) = '/cygdrive'
  cygdrive flags = 0x00000022
HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions\Cygwin\mounts v2\/
  (default) = 'C:\cygwin'
  flags = 0x0000000a
HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions\Cygwin\mounts v2\/usr/bin
  (default) = 'C:\cygwin/bin'
  flags = 0x0000000a
HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions\Cygwin\mounts v2\/usr/lib
  (default) = 'C:\cygwin/lib'
  flags = 0x0000000a
HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions\Cygwin\Program Options

c:  hd  NTFS     49999Mb  22% CP CS UN PA FC
d:  hd  NTFS     49999Mb  54% CP CS UN PA FC
e:  cd             N/A    N/A
w:  net NTFS   1559020Mb  71% CP CS    PA        eberge

C:\cygwin      /          system  binmode
C:\cygwin/bin  /usr/bin   system  binmode
C:\cygwin/lib  /usr/lib   system  binmode
.              /cygdrive  system  binmode,cygdrive

Not Found: awk
Not Found: bash
Not Found: cat
Not Found: cp
Not Found: cpp (good!)
Not Found: crontab
Not Found: find
Not Found: gcc
Not Found: gdb
Not Found: grep
Not Found: kill
Not Found: ld
Not Found: ls
Not Found: make
Not Found: mv
Not Found: patch
Not Found: perl
Not Found: rm
Not Found: sed
Not Found: ssh
Not Found: sh
Not Found: tar
Not Found: test
Not Found: vi
Not Found: vim

   61k 2008/04/01 C:\cygwin\bin\cygbz2-1.dll - os=4.0 img=1.0 sys=4.0
                  "cygbz2-1.dll" v0.0 ts=2008/3/31 22:37
    7k 2003/10/19 C:\cygwin\bin\cygcrypt-0.dll - os=4.0 img=1.0 sys=4.0
                  "cygcrypt-0.dll" v0.0 ts=2003/10/19 2:57
   40k 2006/11/15 C:\cygwin\bin\cygform-8.dll - os=4.0 img=1.0 sys=4.0
                  "cygform-8.dll" v0.0 ts=2006/11/15 1:06
   25k 2008/01/04 C:\cygwin\bin\cyghistory6.dll - os=4.0 img=1.0 sys=4.0
                  "cyghistory6.dll" v0.0 ts=2008/1/3 21:31
  271k 2007/08/24 C:\cygwin\bin\cygicons-0.dll - os=4.0 img=1.0 sys=4.0
                  "cygicons-0.dll" v0.0 ts=2007/8/24 2:24
  976k 2006/10/22 C:\cygwin\bin\cygiconv-2.dll - os=4.0 img=1.0 sys=4.0
                  "cygiconv-2.dll" v0.0 ts=2006/10/22 18:44
   31k 2005/11/20 C:\cygwin\bin\cygintl-3.dll - os=4.0 img=1.0 sys=4.0
                  "cygintl-3.dll" v0.0 ts=2005/11/19 20:04
   31k 2006/10/23 C:\cygwin\bin\cygintl-8.dll - os=4.0 img=1.0 sys=4.0
                  "cygintl-8.dll" v0.0 ts=2006/10/22 19:12
   21k 2006/11/15 C:\cygwin\bin\cygmenu-8.dll - os=4.0 img=1.0 sys=4.0
                  "cygmenu-8.dll" v0.0 ts=2006/11/15 1:05
   67k 2006/11/15 C:\cygwin\bin\cygncurses++-8.dll - os=4.0 img=1.0 sys=4.0
                  "cygncurses++-8.dll" v0.0 ts=2006/11/15 1:13
  237k 2006/11/15 C:\cygwin\bin\cygncurses-8.dll - os=4.0 img=1.0 sys=4.0
                  "cygncurses-8.dll" v0.0 ts=2006/11/15 1:02
   12k 2006/11/15 C:\cygwin\bin\cygpanel-8.dll - os=4.0 img=1.0 sys=4.0
                  "cygpanel-8.dll" v0.0 ts=2006/11/15 1:04
  150k 2008/04/25 C:\cygwin\bin\cygpcre-0.dll - os=4.0 img=1.0 sys=4.0
                  "cygpcre-0.dll" v0.0 ts=2008/4/24 19:30
  303k 2008/04/25 C:\cygwin\bin\cygpcrecpp-0.dll - os=4.0 img=1.0 sys=4.0
                  "cygpcrecpp-0.dll" v0.0 ts=2008/4/24 19:30
    7k 2008/04/25 C:\cygwin\bin\cygpcreposix-0.dll - os=4.0 img=1.0 sys=4.0
                  "cygpcreposix-0.dll" v0.0 ts=2008/4/24 19:30
   22k 2002/06/09 C:\cygwin\bin\cygpopt-0.dll - os=4.0 img=1.0 sys=4.0
                  "cygpopt-0.dll" v0.0 ts=2002/6/9 0:45
  155k 2008/01/04 C:\cygwin\bin\cygreadline6.dll - os=4.0 img=1.0 sys=4.0
                  "cygreadline6.dll" v0.0 ts=2008/1/3 21:31
 1829k 2008/04/17 C:\cygwin\bin\cygwin1.dll - os=4.0 img=1.0 sys=4.0
                  "cygwin1.dll" v0.0 ts=2008/4/17 5:11
    Cygwin DLL version info:
        DLL version: 1.5.25
        DLL epoch: 19
        DLL bad signal mask: 19005
        DLL old termios: 5
        DLL malloc env: 28
        API major: 0
        API minor: 156
        Shared data: 4
        DLL identifier: cygwin1
        Mount registry: 2
        Cygnus registry name: Cygnus Solutions
        Cygwin registry name: Cygwin
        Program options name: Program Options
        Cygwin mount registry name: mounts v2
        Cygdrive flags: cygdrive flags
        Cygdrive prefix: cygdrive prefix
        Cygdrive default prefix:
        Build date: Thu Apr 17 12:11:03 CEST 2008
        CVS tag: cr-0x5f1
        Shared id: cygwin1S4

Can't find the cygrunsrv utility, skipping services check.

Cygwin Package Information
Last downloaded files to: C:\Users\Administrator\Desktop
Last downloaded files from:

Package              Version
_update-info-dir     00732-1
alternatives         1.3.30c-2
ash                  20040127-3
base-files           3.7-1
base-passwd          2.2-1
bash                 3.2.39-19
bzip2                1.0.5-2
coreutils            6.10-1
crypt                1.1-1
cygutils             1.3.2-1
cygwin               1.5.25-12
cygwin-doc           1.4-4
editrights           1.01-2
findutils            4.4.0-1
gawk                 3.1.6-1
grep                 2.5.1a-4
groff                1.18.1-2
gzip                 1.3.12-2
less                 382-1
libbz2_1             1.0.5-2
libiconv2            1.11-1
libintl3             0.14.5-1
libintl8             0.15-1
libncurses8          5.5-3
libpcre0             7.6-2
libpopt0             1.6.4-4
libreadline6         5.2.12-10
login                1.9-7
man                  1.6e-1
rebase               2.4.3-1
run                  1.1.10-1
sed                  4.1.5-2
tar                  1.20-1
termcap              20050421-1
terminfo             5.5_20061104-1
texinfo              4.8a-1
tzcode               2008a-1
which                2.19-1
Use -h to see help about each section


Attachment: bash.stackdump
Description: Binary data

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]