This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Problems installing on vista, no /bin in path


Advance warning - I might be reading the problem I'm struggling
with into this...

Take a look at /var/log/setup.log and look at the postinstall
output.  I'm suspecting that you're running into a problem I've
seen on 2008 where the bash postinstall fails for some reason
(I've at least seen that bash itself is failing for a reason
I'm still trying to understand).

So, here are my questions:

1. Does /var/log/setup.log show postinstall script failures,
   in particular for the bash postinstall?
2. What happens when you run bash from a windows shell?

Unfortunately this might only confirm that we're running into
the same problem, but it would be new information that the
problem can also occur on Vista.  I say "unfortunately" because
I haven't found a solution yet.

I actually suspected that this might occur on Vista SP1 as the
underlying build number (6001) is the same for Vista SP1 and
Windows 2008.  I've done plenty of cygwin installs on Vista without
problems (x86 and x64) but all were done before upgrading to SP1.
Just a suspicion and a week on at that since I have also done some
successfuly Windows 2008 installs of cygwin.

Let me know what you see in these areas and we'll see if I'm barking
up the wrong tree...if not I'll keep you informed if I find more
on this (I have other posts on this to the cygwin mailing list and
will continue to post if I find out more).



----- Original Message ----
From: Steinar Bang <>
Sent: Friday, May 23, 2008 7:50:05 AM
Subject: Problems installing on vista, no /bin in path

I clicked on the setup.exe on the page, and tried
installing cygwin on a Vista system.  The installation seemed to go
fine, but I got an error message at the end.

Still, the cygwin icon appeared on the desktop, and when double clicking
on the desktop I got a bash prompt.

However, I didn't find any other programs.

I've tried re-running the setup.exe as administrator three times.  The
first time I got the same error message at the end.  The second time I
didn't recreate the start menu entry, and the desktop icon, and got no
error message at the end.  The third time I recreated the desktop icon
and start menu entry, but got no error message.

But the behaviour didn't change: no applications were found.

echo $PATH revealed that /bin was not in the PATH.  What's the simplest
way to fix that?

Also, the desktop shortcut set no working directory.  Is this normal?
Shouldn't the working directory be whatever is the working directory of
the user.

The user account I created the cygwin installation under originally, and
am trying to use it under, is a domain user that is local administrator
on the vista machine.

All hints, tips, etc appreciated!


- Steinar

Unsubscribe info:
Problem reports:


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]