This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: cygwin 1.7.8-1 setup produces INVALID PACKAGE entries in setup.log.full

I just tried the latest 1.7.9-1 setup.exe (although it appears to be the same
version used for 1.7.8-1) and get the same results for a clean (new empty
folder) download-only operation.

Is it safe to ignore these errors in the setup log?

These look to me like they could be indicating a download issue. Unfortunately, the message doesn't provide allot of insight into the particular package 'setup.exe' thinks is incomplete/invalid. I'd recommend removing your download directory and trying again. If the problem persists, try multiple mirrors 1 at a time, removing the download directory with each attempt. If it still occurs, you may need to investigate if you have a proxy that's cached some bad data. You should be able to rule that in or out by removing the download directory again and picking a mirror that you've never tried before.

-- Larry

Thank you for your assistance. Unfortunately, I had already tried the process
suggested with a number of mirrors, deleting both the "C:\cygwin" and the
setup "download" directories after each attempt; all to no avail. Also, I do
not have a proxy configured for my side of the network (I am certain that
my ISP does). That said, I tried a few more tests ...

Interestingly, the Cygwin setup downloads without these error messages when
executed within any number of VMs that I run on my Windows 7 64-bit host. In
addition, the same is true for other physical Windows XP systems on my network.
And, all using the same mirrors. Therefore, it appears that I am being plagued by
a specific issue on my physical Windows 7 machine itself; although it is a relatively
recent development. I do not believe this is a BLODA issue, but I have not
thoroughly ruled that out ... anything is possible at this point.

Just for the record, on my Win7 host I am running ESET's NOD32 64-bit
antivirus and, as a test, I had disabled that too, also to no avail.

At any rate, the downloads acquired from the VMs and physical XP systems
_DO_ compare exactly as those acquired from the same mirror on my
Windows 7 host. This would seem to indicate that, in general, it is not a network
issue. So, the errors reported within the setup.log.full file seems to be more of a
nuisance than anything else. I will continue to try to isolate the problem.

In the meantime, if anyone else has experienced this condition, I would certainly
appreciate hearing about it. At the very least it would help me to keep my sanity.

Thank you for your continued assistance and all of your hard efforts creating and
refining Cygwin ... it has been invaluable to me over the last several years. :-)

Kind regards,

-- Problem reports: FAQ: Documentation: Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]