This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: /proc/*/cmdline corrupted

On 10/13/2011 11:02 AM, Jon Clugston wrote:
On Wed, Oct 12, 2011 at 11:07 AM, Jon Clugston<> wrote:

When I run "procps -ef" I get corrupted command line parameters:

jc807j@~>procps -ef
jc807j    5852     1  0 08:59 tty0     00:00:03 X :0 -multiwindow
jc807j    2668     1  0 08:59 tty0     00:00:00 xterm -e ssh server
80x72+285+0 -e ssh server
jc807j    3004     1  0 08:59 tty0     00:00:00 xterm -e ssh server
80x72-8+0 -e ssh server
jc807j    3392  3004  0 08:59 tty0     00:00:00 ssh server
jc807j    5960  2668  0 08:59 tty1     00:00:00 ssh server
jc807j    2928  5852  0 09:12 ?        00:00:00 xterm  20000 +tb
jc807j    4608  2928  0 09:12 tty2     00:00:00 bash
jc807j    5800  4608  1 10:57 tty2     00:00:00 procps -ef

The actual command lines for the 3 xterm processes are:

C:\cygwin\bin\xterm.exe -sl 20000 +tb -geometry 80x72+285+0 -e ssh server
C:\cygwin\bin\xterm.exe -sl 20000 +tb -geometry 80x72-8+0 -e ssh server
C:\cygwin\bin\xterm.exe -sl 20000 +tb

as reported by the "listdlls" tool.

I have verified that the "/proc/*/cmdline" is the source of the
corrupted information.  "cmdline" from PID 2928 is:

jc807j@~>od -c /proc/2928/cmdline
0000000   x   t   e   r   m  \0  \0   2   0   0   0   0  \0   +   t   b
0000020  \0

I am able to reproduce the problem by simply executing the following
command line:

xterm -sl 20000 +tb -geometry 80x72+285+0 -e ssh server

(obviously w/ X running). I wrote a simple shell script which does
nothing except sleep and I called it with the same command line
parameters and it didn't have the problem. So, it appears that the
problem is related to "xterm" or something that "xterm" does.

I also shortened/simplified the command line (to "xterm") and it was
still corrupted (the "-sl" was missing):

xterm -sl 20000 +tb -geometry 80x72+285+0

I tried to reproduce by creating long command lines to other commands
and none were corrupted.

Does "xterm" step on its command line?
While not an answer to your question, why not just put the following in your ~/.Xdefaults:

   serverTerm*saveLines: 20000
   serverTerm*toolBar: false
   serverTerm*geometry: 80x72+285+0

and invoke xterm with:

$ xterm -name serverTerm -e ssh server

and be done with it?

Andrew DeFaria <>
You know how it is when you're walking up the stairs, and you get to the top, and you think there's one more step? I'm like that all the time.

-- Problem reports: FAQ: Documentation: Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]