This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: base-files problem

On Thu, Feb 16, 2012 at 12:22:25PM -0600, René Berber wrote:
> Hi,
> The changes in base-files deleted everything from /etc/skel, I
> re-installed 4.0-9 and still nothing.
> I can see in the package list that there should be the usual files
> there, did some post-install script deleted those files?
> Anyone seen the same problem? (i.e. your bash prompt changed, no longer
> shows the current directory).
> Any idea what is causing this?  It started yesterday after I updated a
> few packages, base-files was not even listed as installed, which is
> strange, I then re-installed it.

I have just updated a box from base-files-4.0-6 to 4.0-9 and
everything worked as expected. I tried both with locally modified and
unmodified skel files.

$ grep base-files /etc/defaults/etc/skel/.*
/etc/defaults/etc/skel/.bash_profile:# base-files version 4.0-9
/etc/defaults/etc/skel/.bashrc:# base-files version 4.0-9
/etc/defaults/etc/skel/.inputrc:# base-files version 4.0-9
/etc/defaults/etc/skel/.profile:# base-files version 4.0-9

The process of checking wether the files have to be replaced has not
changed since 4.0-4 (march 2011) at least. And IIRC, it was barely the
same in the 3.x version as well.

If reinstalling fails as well, does an error get printed?

Huella de clave primaria: AD8F BDC0 5A2C FD5F A179  60E7 F79B AB04 5299 EC56

Attachment: signature.asc
Description: Digital signature

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]