This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: base-files problem

On 2/16/2012 2:41 PM, David Sastre Medina wrote:

> I have just updated a box from base-files-4.0-6 to 4.0-9 and 
> everything worked as expected. I tried both with locally modified
> and unmodified skel files.
> $ grep base-files /etc/defaults/etc/skel/.* 
> /etc/defaults/etc/skel/.bash_profile:# base-files version 4.0-9 
> /etc/defaults/etc/skel/.bashrc:# base-files version 4.0-9 
> /etc/defaults/etc/skel/.inputrc:# base-files version 4.0-9 
> /etc/defaults/etc/skel/.profile:# base-files version 4.0-9
> The process of checking wether[SIC] the files have to be replaced
> has not changed since 4.0-4 (march 2011) at least. And IIRC, it was
> barely the same in the 3.x version as well.
> If reinstalling fails as well, does an error get printed?

Its not /etc/defaults/etc/... but /etc/skel/.*, and the files where
not deleted, just changed in a way I no longer had a PS1.  I also lost
PROMPT_COMMAND which also showed the current directory.  Its possible
that I had changed them so the problem is really that those files
where replaced, probably my mistake if I had modified the wrong files
(I thought the /etc/skel where the ones I should modify, and not touch
the /etc/defaults/ files).

When I did the update there where no Cygwin processes running, so I
did not have any message about stopping anything and retrying, or
needing reboot.  But another strange thing was that a new terminal
(with a login shell) did not put me at my $HOME directory, until later
after I re-installed.

The log doesn't show any erros:

> $ tail /var/log/setup.log
> 2012/02/15 19:31:43 Downloaded C:\Cygwin\tmp/
> 2012/02/15 19:31:47 Downloaded C:\Cygwin\tmp/
> 2012/02/15 19:31:49 Extracting from file://C:\Cygwin\tmp/
> 2012/02/15 19:31:49 Extracting from file://C:\Cygwin\tmp/
> 2012/02/15 19:31:52 Changing gid back to original
> 2012/02/15 19:31:52 running: C:\Cygwin\bin\bash.exe --norc --noprofile /etc/postinstall/
> 2012/02/15 19:31:54 running: C:\Cygwin\bin\bash.exe --norc --noprofile /etc/postinstall/
> 2012/02/15 19:31:55 Changing gid to Administrators
> 2012/02/15 19:32:00 note: Installation Complete
> 2012/02/15 19:32:00 Ending cygwin install

And there are no .new files left, or post-install scripts with a name
not ending in .done .
René Berber

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]