This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Problem after upgrading from 1.7.9 to 1.7.10-1 - system commands not found

On Fri, Feb 24, 2012 at 03:44:46PM -0500, Bilig Ordos wrote:
> I've been happy with 1.7.9, but couldn't resist my curiosity so ran
> the 1.7.10-1 setup today. During the process it complained that Cygwin
> is running and offered me options to either stop the Cygwin and try
> again, or continue and reboot after it is done. So I selected to
> continue and then rebooted.
> But when I launched the Cywin console/Mintty, I did not have most of
> the system commands, such as "ls" and "which", but commands like "cd"
> and "alias" are there.
> I tried running the setup again (made sure all the packages I used to
> have are selected) but did not help. rebooted again and it is the
> same.
> How can I recover from this? I hate to reinstall from scratch as doing
> that will make me lose a lot of customization, such as ssh keys, etc.
> Please see below for examples and logs.

Don't panic. Your keys are still there. Also, please don't put a log
into the body of the email. It's a better idea to attach it.

> Problem reports:

Your problem could have been caused by incorrect permissions in the latest 
base-files' package contents.

> 2012/02/24 14:33:39DownloadedC:\Users\boyun\Downloads/
> 2012/02/24 14:34:07Running preremove script for  base-files
> 2012/02/24 14:34:07running: C:\cygwin\bin\bash.exe --norc --noprofile
> /etc/preremove/
> 2012/02/24 14:34:10Uninstalling base-files
> 2012/02/24 14:34:11Extracting from
> file://C:\Users\boyun\Downloads/
> 2012/02/24 14:35:10running: C:\cygwin\bin\bash.exe --norc
> --noprofile/etc/postinstall/
> 2012/02/24 14:35:14running: C:\cygwin\bin\bash.exe --norc
> --noprofile/etc/postinstall/

Please check and correct perms if necessary in:


All of them should have owner/group root.root and 644 perms (rw-r--r--)
Afterwards, close all cygwin apps and restart a mintty session.
Please report back if that solved your issue.

Huella de clave primaria: AD8F BDC0 5A2C FD5F A179  60E7 F79B AB04 5299 EC56

Attachment: signature.asc
Description: Digital signature

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]