This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Recent Cygwin problems

I've had Cygwin installed on this computer for over two years
without any problems but recently I've started seeing a few problems
and my installation seems corrupted.

1.  Starting several weeks ago, whenever I run setup.exe I get this
    pop-up message part way through the process.

        Cygwin Setup - Running postinstall scripts

        Postinstall script errors
            These do not necessarily mean that affected packages
            will fail to function properly, but please check
            /var/log/setup.log.full and report any problems.

        Package: Unknown package
        exit code 1

    The relevant lines from /var/log/setup.log.full (following a
    reinstall of the mutt package) seem to be these at the end:

        2013/06/21 10:05:29 running: C:\cygwin\bin\bash.exe --norc --noprofile "/etc/postinstall/"
        2013/06/21 10:05:30 running: C:\cygwin\bin\bash.exe --norc --noprofile "/etc/postinstall/"
        /etc/postinstall/ line 1: /etc/pango/pango.modules: No such file or directory
        2013/06/21 10:05:30 abnormal exit: exit code=1
        2013/06/21 10:05:30 Changing gid to Administrators
        2013/06/21 10:07:23 note: Installation Complete
        2013/06/21 10:07:23 Ending cygwin install

2.  I installed the ttrack time tracking tool from  It initially worked fine.
    Following the running of setup.exe on Wednesday to bring my
    installation up to date, ttrack now generates these errors when
    started, but it seems to run fine.

        $ ttrack

        TimeTrack 1.1.0

        Type 'help' to list commands.

        ttrack>>> Exception in thread Thread-1:
        Traceback (most recent call last):
          File "/usr/lib/python2.7/", line 551, in __bootstrap_inner
          File "/usr/lib/python2.7/site-packages/ttrack-1.1.0-py2.7.egg/EGG-INFO/scripts/ttrack", line 288, in run
            updater = tracklib.LastSeenUpdater(self.__db)
          File "/usr/lib/python2.7/site-packages/ttrack-1.1.0-py2.7.egg/", line 380, in __init__
            self.conn = sqlite3.connect(db.filename)
        OperationalError: disk I/O error

3.  I ran "cygcheck -c" today to see what it might tell me.  It

        mutt                                  1.5.20-1             Incomplete

    so I ran setup.exe to reinstall the mutt package.  The package
    is still incomplete:

        $ cygcheck -cv mutt
        Cygwin Package Information
        Last downloaded files to: C:\Documents and Settings\gajohnso\Application Data\Cygwin
        Last downloaded files from:

        Package              Version        Status
        Missing file: /etc/Muttrc.setupnew from package mutt
        Missing file: /etc/mime.types.setupnew from package mutt
        mutt                 1.5.20-1       Incomplete

4.  I ran "cygcheck -srv" which indicated several problems,
    including "Not found: gcc", so I tried reinstalling gcc but
    cygcheck still shows the same message.

Would someone please take a look at the attached output of "cygcheck
-srv" (including the messages to stderr) and let me know how I might
fix this mess?  (I sanitized it only to the extent of changing some
names to "MY...".)

I had been installing packages from but changed to in case the repository had become corrupted,
but I didn't see any difference.


Attachment: cygcheck.out
Description: Text document

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]