This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Problem with "None" Group on Non-Domain Members

On May  5 10:17, Chris J. Breisch wrote:
> Corinna Vinschen wrote:
> >On May  5 09:49, Chris J. Breisch wrote:
> >As far as Cygwin tools are concerned, the None group is just a normal
> >group like any other group.  The behaviour you're observing looks a bit
> >like either your group file is not ok, or you're testing this with the
> >noacl mount option.  Or, probably more likely, you're suffereing from
> >the default ACL settings propagated from the parent directory.
> >
> >When Cygwin sets the POSIX permissions, it does exactly the same thing
> >for the primary group in your token, whether it's None or any other
> >group.
> >
> >
> I understand what you're saying, but I don't think the behavior
> agrees with your statements. I've tried this on a couple different
> machines, and the behavior is identical. No matter what I do, if a
> file is created with the "None" group, the group file permissions
> are always identical to the owner file permissions. I've tried
> playing with my umask and with directory sticky bits. It doesn't
> matter.

I wasn't talking about the POSIX permissions, but about the Windows
ACL.  In your current dir, what does `icacls .' print?  Maybe that
gives a clue.

> In the example above, my parent directory is rather oddly,
> Chris.Users 000. The current directory is Chris.None 775.

I just tried it myself with a local machine account and I can't
reproduce this.  My pgid is "None" and the umask of 0022 leads to the
expected POSIX permissions:

  vmbert8164+lcorinna@vmbert8164 ~
  $ umask

  vmbert8164+lcorinna@vmbert8164 ~
  $ touch bar

  vmbert8164+lcorinna@vmbert8164 ~
  $ ls -l
  total 0
  -rw-r--r-- 1 vmbert8164+lcorinna vmbert8164+None 0 May  5 16:41 bar

> [...]
> Taking the example one step farther:
> $ chmod 600 bar
> $ ls -l bar
> -rw-rw---- 1 Chris None 0 May  5 10:10 bar
> $ chmod 400 bar
> $ ls -l bar
> -r--r----- 1 Chris None 0 May  5 10:10 bar

  vmbert8164+lcorinna@vmbert8164 ~
  $ chmod 400 bar

  vmbert8164+lcorinna@vmbert8164 ~
  $ ls -l bar
  -r-------- 1 vmbert8164+lcorinna vmbert8164+None 0 May  5 16:41 bar

So I'd say it's not a generic issue but something in your environment.
It would be nice to know what that is, of course.  Maybe there's some
security setting?!?


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat

Attachment: pgp0haki47QQz.pgp
Description: PGP signature

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]