This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Upgrading from vesrion 1.7.10 to 1.7.29 made stop working my programs


I had some machines with Cygwin version 1.7.10 installed on some windows 7 machines running some tests for a program I developed. One of the exes I run takes some parameters by specifying the flag -D. I normally specify two or three of this parameters using the -D flag without any problem.

After a while. We moved to windows 8 so I decided to download and use the last Cygwin version and I installed 1.7.29. When I tried to run the same commands using this new version I realized that if I only specified one parameters using the -D flag everything worked fine but if I specified more than one, the second parameter afterwards weren't recognised making the program to crass.

I took a look at the changes made from version 10 to version 29 and I cannot see anything that may cause this issue. I also installed this new version on windows 7 to make sure that error was a problem of windows 8. Also, using this machines cmd I can run the commands without any problem.

Thanks for your help,


Please consider the environment before printing this e-mail.

Micro Focus Limited is registered in England and Wales. Registered number: 01504593 Registered office: The Lawn, 22-30 Old Bath Road Newbury, Berkshire, RG14 1QN, UK

This message has been scanned for malware by Websense.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]