This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

xgettext does not work with *.lua files in current versions

I just noticed that xgettext does not work with *.lua files with
current version of cygwin.
I am using it from a bat file where It has worked for a "long time",
but some thing has gone wrong recently.

By "not working" I mean that it seems to do nothing, no output file or
console messages are generated. If I use the --help option or if I
don't give it any input files I get the correct informational message,
but with actual files, if they include any .lua files, nothing.

The --debug options gives no output.

I have tested both the 32 and 64 bit versions with similar results.

I think that the previous version of xgettext did not support .lua
files, so it handled them as C files, which worked just fine for me.
The latest xgettext releases have added .lua support, so it no longer
works... Maybe something is missing from the packaging, or


PS. the attached cygcheck.out shows gnuwin32
 in my path, I have installed it since my original tests, because I
needed a working xgettext!

Attachment: cygcheck.out
Description: Binary data

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]