This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: httpd immediate segfault on startup

On 8/2/2015 10:52 AM, Marco Atzeri wrote:
> On 7/31/2015 6:18 PM, Jim Garrison wrote:
>> On 7/26/2015 5:24 PM, Jim Garrison wrote:
>>> Updated all cygwin packages to current versions, installed httpd
>>> 2.4.16-1.  On startup httpd segfaults:
>>> Exception: STATUS_ACCESS_VIOLATION at eip=65DC5D78
>>> eax=8004E028 ebx=00000001 ecx=00000000 edx=8004DFF0 esi=80014490
>>> edi=80016498
>>> ebp=0028CC78 esp=0028CB5C program=C:\cygwin\usr\sbin\httpd.exe, pid
>>> 25500, thread main
>>> cs=0023 ds=002B es=002B fs=0053 gs=002B ss=002B
>>> Stack trace:
>>> Frame     Function  Args
>>> 0028CC78  65DC5D78 (00000003, 0028CC9C, 80010100, 00000020)
>>> 0028CD28  6100846A (00000000, 0028CD84, 610074F0, 00000000)
>>> End of stack trace
>> Is the maintainer of the httpd package on the list? If not, can
>> someone provide a point of contact? I'd like to investigate this if
>> possible but need guidance on how to proceed.
> He is on the list, but a bit busy I would say.
> the second frame address is
>  $ addr2line.exe -e /usr/bin/cygwin1.dll 0x6100846A
> /usr/src/debug/cygwin-2.1.0-1/winsup/cygwin/
>       cygwin_exit (user_data->main (__argc, newargv, *user_data->envptr));
> so it seems that the process initialization went wrong.
> Have you tried to reinstall httpd ?
> May be the file was damaged
> It should be
> 2015-07-19 19:43      754717 usr/sbin/httpd.exe
> The first address 65DC5D78 seems over the cygwin area.
> Cheers
> Marco

I tried reinstalling with no luck.

I think the exception and stack trace are secondary to the main
problem, which is described by the two messages in the error_log:

(88)Function not implemented: AH00023: Couldn't create the proxy mutex
(88)Function not implemented: AH02478: failed to create proxy mutex

The exception goes away if I remove mod_perl from the configuration,
but the errors and failure to configure are the same.  I also tried
launching httpd in a mintty shell that was started with administrator
privilege level, but the same error occurs.

The "Function not implemented" seems to indicate something mis-matched
in my system but I cannot figure out what.

Jim Garrison (
PGP Keys at RSA 0x04B73B7F DH 0x70738D88

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]