This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: xorg-server 1.17.2-1 and dexpot - X11 windows disappear

I received an e-mail this morning from a gentleman named Joachim
KÃnig-Baltes concerning this issue.  He found an old post in the
Dexpot forums with a different issue, but the solution is working for
him (and for me) and now the latest version of xorg-server in Cygwin
is working with Dexpot again.

The forum post is here:

This post has a file to download and place into the Dexpot
installation directory.  Restart Dexpot and it will work correctly
with xorg-server 1.17.2-1 again.

In case that forum post goes away, the solution is to create a file
name 'myweschsel.ini' in the Dexpot install directory and simply put
the following 2 lines in it and restart Dexpot.


Thanks to Joachim for finding and sharing this solution!

On Mon, Aug 3, 2015 at 2:29 PM, Nem W Schlecht <> wrote:
> Finally got a little time to test this a little bit.  Unfortunately,
> all I can really say is that Dexpot gets confused with X11 application
> windows with xorg-server 1.17.2-1 but was completely fine/working with
> xorg-server 1.17.1-5.
> Here's what I did just now to test:
> 1) Opened up 3 xterms on Desktop 1 of dexpot
> 2) Created directories 'one', 'two' and 'three' in my home directory
> and cd'ed each xterm into these dirs respectively (this ensured that
> each xterm has a unique title)
> 3) Minimized xterm "three" to the status bar in Windows, leaving one
> and two alone
> 4) Switched to desktop 2, waited 3 seconds, switched back to desktop 1
> 5) xterms "one" and "two" have disappeared.  xterm "three" is still in
> the status bar and be restored and looks fine
> 6) ran a 'ps -ef' looking for 'xterm' - I can see all three.
> 7) dexpot has a 'Desktop Windows' dialog that will list all windows -
> even hidden ones.  Only xterm "three" shows up in this list.
> 8) Right clicked on X in the task bar and de-selected "Hide Root
> Window" - only xterm "three" shows up - neither of the other 2 do.
> Any recommendations on how to test this issue further?
> On Tue, Jul 28, 2015 at 11:18 AM, Nem W Schlecht <> wrote:
>> Just tried the new 1.17.2-1 xorg-server - server starts fine, can open
>> windows, etc.
>> I also use Dexpot ( as a virtual desktop manager.
>> When I switch away from a desktop with X11 apps running in it and then
>> switch back, all of my windows have disappeared and their icons are no
>> longer in the taskbar.  If I open up a new window and check my
>> processes, the apps are still running.
>> I'll do some more debugging and report back, but I wanted to get an
>> FYI out.  dexpot + Cygwin X11 has worked flawlessly in previous
>> versions.
>> --
>> Nem W Schlecht         
>> Empyreal Technologies
>>  "Perl did the magic.  I just waved the wand."
> --
> Nem W Schlecht         
> Empyreal Technologies
>  "Perl did the magic.  I just waved the wand."

Nem W Schlecht         
Empyreal Technologies
 "Perl did the magic.  I just waved the wand."

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]