This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Some programs (vi, ssh) crash when screen buffer height is big

Thanks Warren.

> Actually, it did here.

I see it separate, at least in a Web browser:

- This thread:
- The original thread I tried to reply to:

My intention was to reply to this message:

> You are aware that Microsoft is giving out free Windows 10 upgrades to valid Windows 7 license holders, right?

Yeah - however, wanted to test under relatively same conditions
considering what I use daily and I don't decide when to get the
upgrade here...

> but also because I continue to be unable to reproduce your symptom under Windows 10

Just to confirm - you did set the params of cmd.exe one to this:

Screen Buffer Size: 208w 9999h
Window Size: 208w 69h

the files you headed have long lines and you are using 64bit Cygwin?
Those two seem really important. I did not have issues with 32bit. I
seem not to have issues with smaller windows / buffer sizes. I also
don't seem to be able to reproduce when files have short lines.

> Iâve also failed to reproduce your symptom under MinTTY

I cannot reproduce under mintty either.

> (You can make the test script time(1)-able by adding â-c qâ to the vim command, so that it immediately quits after loading the log file.)

Nah, not needed that much - it crashes itself most of the time :)

> When you say âcompletely freshâCygwinâ, do you mean that you didnât even start with an archive of downloaded packages?

Yep - I basically had a fresh Win 7 and used internet to download all things.

>  Did you use a different package mirror?

Yes - I can try with the same mirror if you think that would make a
difference. Given that I am constantly (as in - 20 times a day at
least) reproducing this on three different machines, different
versions of Cygwin (I likely updated it a few times since last year),
etc., I would say that's not very likely a cause.

> I donât know if this is relevant, but have you done a memtest86 (or similar) pass on that machine?  Dodgy RAM could explain intermittent calloc() failures.

It's actually two different machines. One is physical and one a VM on
a totally different physical machine. I also tried it on a third VM
(which is on a third physical machine). It should not be machine

Note that I get a lot of different behaviors, here are some:

- cmalloc would have returned NULL that you referenced
- Garbage on screen - e.g. my PS1 has some ANSI color escape codes and
they look not to be interpreted when it goes into this state. I have:


and instead of making text red, it actually prints


- Mixed text - e.g. I scroll a line in vim (but happens also with
less, cat, etc.) and it doesn't clear the screen completely, i.e.
mixes old and new contents
- Segfaults

It's very interesting that only I can reproduce. Cannot pinpoint what
can be the difference between the envs... :(

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]