This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Sshd behaving strangely...

>> Please teach your mail agent to not break threading.

Sorry for this. Yes, this particular mailer is really bad,
I'll have to re-register with the Cygwin mail list from 
a better one.

>> This is a different issue, judging from the error message. 
>> [...]
>> A verbose log of the same connection from both server 
>> and client may help. 

I've attempted a connection from another account on the machine
from which I could not do so previously, with ssh -v and...
it worked! I made a successful connection. So, then I went
back to the account from which I could not connect, ran ssh -v
and I got the following:

debug1: Offering RSA public key: /home/[user_name]/.ssh/id_rsa
Connection closed by [ip_number]

Aha! So it's my old RSA key that's the culprit here. I removed
it and this time the connection worked just fine! 

In summary, it appears that it all works as it ought to right
out of the box. I configured sshd on the target machine with
the "-y" option, which, I presume, builds a default server

My only suggestion would be that, if the connection is refused
the reason for refusal should perhaps be printed back to the
user, even without the -v option.

Many thanks for your help. 

Zdzislaw (Gustav) Meglicki
Indiana University


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]