This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: convert does nothing - issue with cyglcms2-2 dll?

Greetings, Katriel Friedman!

> I'm running Windows 7, 64 bit, with Cygwin 64-bit installed from the 2.871
> installer. The Imagemagick "convert" command returns the prompt
> immediately, even when followed by gibberish, e.g. "convert adsfasdf". I
> first observed the problem with Imagemagick I tried
> uninstalling and reinstalling Imagemagick, and restarting Cygwin, and the
> problem remained. I also tried downgrading to, and the problem
> still remained.

> When I start convert.exe directly from windows Explorer I get the pop-up
> error "the procedure entry point cmsCreateContext could not be located in
> the dynamic link library cyglcms2-2.dll". I also tried reinstalling
> liblcms2-2 to no avail.

Do you have Cygwin path set in Windows? This isn't the case in a normal
install, which would explain such effect.

> I know in the past this problem has occurred because of missing XOrg DLLs
> ( but I'm not
> sure where to look for those DLLs now.

I'm not observing your problem, WJFFM.

$ uname -a; convert --version
CYGWIN_NT-6.1 daemon2 2.2.1(0.289/5/3) 2015-08-20 11:42 x86_64 Cygwin
Version: ImageMagick 6.9.1-3 Q16 x86_64 2015-07-01
Copyright: Copyright (C) 1999-2015 ImageMagick Studio LLC
Features: DPC OpenMP
Delegates (built-in): autotrace bzlib cairo fftw fontconfig freetype fpx gslib jbig jng jpeg lcms lzma pangocairo png ps rsvg tiff webp x xml zlib

With best regards,
Andrey Repin
Sunday, October 11, 2015 18:44:29

Sorry for my terrible english...

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]