This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: reading from pipes fails if working directory is on a removable drive

On 28/04/2016 23:16, mihau wrote:

came across this today on a fresh (2 days old) installation of cygwin x86

$ cat test.txt | head
      3 [main] head (3348) C:\tools\cygwin\bin\head.exe: *** fatal error
- MapViewOfFileEx '(null)'(0x5DC), Win32 error 6.  Terminating.
Segmentation fault

reading from pipes works fine if working directory is a local drive or a
UNC path,
but this happens if the working directory is removable drive. I tried
with/on various
devices and it happens on all removable drives, regardless of the
filesystem (NTFS or FAT32)

also, 'head' is just an example; the same error comes up when trying to
use grep,
sed or gawk (haven't tested with others yet).

does anybody know what could be causing this?

thank you,

My cygwin is on a removable drive so your experience
is not normal.

I guess some BLODA.

As suggested on

"Run cygcheck -s -v -r > cygcheck.out and include that file as an attachment in your report. Please do not compress or otherwise encode the output. Just attach it as a straight text file so that it can be easily viewed. "

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]