This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: reading from pipes fails if working directory is on a removable drive

On 29.04.2016 15:23, Marco Atzeri wrote:

As next step, can you remove it ?
Some can interfere also when disabled.

I did think about it for a second but actually that's not an option;
also it never interfered with cygwin or any other application.

In addition you can run

   strace -o pipe.strace cat test.txt |head

on fix and removable drive. May be will give some additional hint.

exact same result as described in the original post

To see if any program is injecting dll's on your system
you can also looks on /proc/self/maps

$ cat /proc/self/maps | awk '{print $6}' |sort -u


looks largely like your output, plus the stuff in square brackets at the end

I forgot one question :
  did your XP system ever worked with a cygwin installation ?

yes, I've been using it (at least) for the past five years largely without any issues

I doubt latest cygwin changes broke XP, but may be it happens.

at the end of the day I can still work with it, as long as working directory is on a fixed drive -
it's just a little annoying

anyway, many thanks for your help :)

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]