This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Vim responds too slow on the latest snapshot of cygwin1.dll

On Jun  6 09:50, Chris Sutcliffe wrote:
> On 6 June 2016 at 07:05, Takashi Yano wrote:
> >
> >> Just as John I can't reproduce this.  What OS version do you run this
> >> on, and is it 32, 32 under WOW64, or 64 bit?
> >
> > OS: Windows 7 (64bit)
> > Cygwin: Both 32bit and 64bit
> >
> > I have tested on two Win7 machines, and the problem
> > occurs on both machines.
> >
> > Further, this problem occurs in Windows 7, but does
> > not occur in Windows 10, as far as I tested.
> >
> > Can you possibly test on Win7 machine?
> I can confirm that I see this behaviour on 64bit Windows 7 running
> 64bit Cygwin using the newly released snapshot (06/06/16).  If there
> is anything I can do to assist with debugging the issue please let me
> know.

Thanks for the offer.  I could actually reproduce it on a W7 32 bit
machine.  I found the problem and fixed it.  While I was at it, I
improved the timer handling in select_stuff::wait a bit.

What I'd *really* need now is people testing the latest snapshot on ASAP and throw at it what they can think
of.  Is there still a regression compared to 2.5.1?  If so, please

Thanks to all of you,

Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat

Attachment: signature.asc
Description: PGP signature

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]