This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: git 2.8.3 spurious output

> On 6/8/2016 10:19 AM, Cufi, Carles wrote:
> On 6/8/2016 9:57 AM, Cufi, Carles wrote:
> Hi there,
> On 6/8/2016 5:35 AM, Cufi, Carles wrote:
> Hi,
> When running git 2.8.3 with certain of its commands (submodule for
> example) I get spurious output on the terminal:
> cacu ~/src/nordic/gh/pc-ble-driver-py (master) $ git submodule deinit .
> ': not a valid line 88: export: `displaypath Cleared
> directory ''
> ': not a valid line 88: export: `name
> ': not a valid line 88: export: `url
> ': not a valid line 88: export: `displaypath
> Submodule '' () unregistered for path ''
> The variables referenced above (displaypath, name, url) seem to be part
> of the git-submodule script in /usr/libexec/git-core.
> It looks like output lines are being overwritten, which suggests that
> you have DOS line endings somewhere (maybe in git-submodule?). For
> example, there seems to be a reference to line 88 of,
> partially overwritten by something else. (Notice that git-submodule
> calls eval_gettext many times; the latter is defined in
> /usr/bin/
> That's one of the first thing I tried, I ran:
> $ dos2unix /usr/libexec/git-core/git-submodule
> But the spurious output is still there.
> There doesn't seem to be a /usr/bin/ in my Cygwin
> installation.
> I see that you have some msys stuff in your path. Do you have
> there? ('which' should find it.)
> Yep, that's it!
> $ which
> /cygdrive/c/mingw/bin/
> So what's the better way of fixing this? Making /mingw/bin/
> have UNIX line endings or replacing it with the proper Cygwin
> that I seem to be missing?
> One solution would be to install Cygwin's gettext package, so that
> Cygwin's precedes MinGW's in your path. (Note that git
> doesn't require gettext; it's not needed because git-sh-i18n provides a
> definition of eval_gettext on systems that don't have it.

This worked like a charm. Installed cygwin's own gettext package and now I get no more spurious output.
Thanks so much for that.

> In general, however, it seems to me that you're asking for trouble by
> having MinGW binaries in your path while working in Cygwin.

Yep, I want to do that but the problem is that Cygwin inherits the global PATH from Windows and MinGW is present there. I guess I could somehow remove it from the path with a script in my .bashrc when bash opens.

Thanks again,


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]