This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: duplicity/gpg secret key error


We have tried it with virtualized versions of Windows 7 Ultimate and
Windows 8.1 (32 and 64 bits) and the error keeps the same, but we
succeed with the same settings inside a no virtualized Windows 7

Is there any problem with virtualization? We don't know what to do
from now. Tomorrow we'll test the same config inside a no virtualized
Windows 8.1.

Thank you,

  Mario Barcala

Mario Barcala wrote:
> Hi all:
> We are trying to configure duplicity to make backups of a Windows 7
> machine (32 bit) and we get the following error:
> > $ duplicity full --encrypt-key=6F84684A /cygdrive/c/Documents\ and\
> > Settings scp://user@ip/directory
> > Synchronizing remote metadata to local cache...
> > GnuPG passphrase:
> > Copying duplicity-full-signatures.20160421T110618Z.sigtar.gpg to local
> > cache.
> > Cleanup of temporary directory /tmp/duplicity-0QQxWE-tempdir failed - this
> > is probably a bug.
> > GPGError: GPG Failed, see log below:
> > ===== Begin GnuPG log =====
> > gpg: encrypted with RSA key, ID 65A86B7F
> > gpg: decryption failed: secret key not available
> > ===== End GnuPG log =====
> Notice that gpg key ID 65A86B7F is different from the one specified by
> us 6F84684A. We have tried to use symetric encryption (removing
> --encrypt-key=6F84684A), and even to specify --no-encryption, but the
> error keeps the same.
> We have reinstalled cygwin in a clean Windows machine and the error
> arise the same (with the same RSA key id: 65A86B7F).
> Any idea about the problem?
> Any help will be appreciated.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]