This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Notmuch mail indexer - talloc requirement?

On 6/11/2016 7:01 PM, David Stacey wrote:
On 11/06/16 19:55, Jack Ostroff wrote:
I was able to complete the talloc compile and install by going
into the bin/defaults directory and linking cygtalloc_2.dll to both
talloc.dll and cygtalloc.dll, and the same for cygpytalloc-util-2.dll.

However, even then, when doing ./configure on notmuch I still get errors:

/usr/include/xapian/version.h:28:2: error: #error The C++ ABI version of
compiler you are using does not match

/usr/include/xapian/version.h:31:2: error: #error The Xapian library was
built with g++ 4.8.3
  My current g++ is 5.3.0.

Does this help?

    ./configure CXXFLAGS="-g -O2 -D_GLIBCXX_USE_CXX11_ABI=0"

It should force the compiler to use to older ABI.
Oddly, no. With that line, I get "Unrecognized option: CXXFLAGS=-g -O2 -D_GLIBCXX_USE_CXX11_ABI=0". Passing it as an environment variable seems to have no effect. (I thought I had recompiled xapian, which I thought would have used the new ABI, but even that didn't seem to make any difference.)

Other ideas?

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]