This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Cmake on cygwin64 fails with error "C compiler "/usr/bin/cc" is not able to compile a simple test program"

I am having trouble building an open source project using cmake under Cygwin64 with the latest tools (setup-x86_64.exe version 2.874).  

I was able to successfully build the project with 32-bit Cygwin with the latest tools:  gcc 5.4.0, gnu make 4.2.1, and cmake 3.3.2.

I was also able to successfully build the project under Cygwin64 using older tools: gcc 4.9.3, gnu make 4.1, and cmake 3.3.2.

But when I updated my Cygwin64 installation to the latest tools (gcc 5.4.0, gnu make 4.2.1, cmake 3.3.2) the build failed with the error message below.  I tried wiping my Cygwin64 installation and reinstalling from scratch but got the same result.  I thought it might be a PATH problem so I set my path the "/usr/bin" and still got the same result.  The CMakeFiles/CMakeTmp directory mentioned in the error message below was created, but there's nothing in it.

Can someone provide some advice that can help me fix my Cygwin64 installation so that cmake works properly?

       -- Frank

$ cmake -DOPENVX_INCLUDES=$OPENVX_DIR/include -DOPENVX_LIBRARIES=$OPENVX_DIR/out/CYGWIN/x86_64/release/libopenvx.dll.a\;$OPENVX_DIR/out/CYGWIN/x86_64/release/libvxu.dll.a ../conformance_tests/
-- The C compiler identification is GNU 5.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- broken
CMake Error at /usr/share/cmake-3.3.2/Modules/CMakeTestCCompiler.cmake:61 (message):
  The C compiler "/usr/bin/cc" is not able to compile a simple test program.

  It fails with the following output:

   Change Dir: /cygdrive/c/Users/f.brill/Documents/OpenVX/trunk/packages/v_1_1/build64/CMakeFiles/CMakeTmp

  Run Build Command:"/usr/bin/make.exe" "cmTC_5d15a/fast"

  /usr/bin/make -f CMakeFiles/cmTC_5d15a.dir/build.make

  make[1]: Entering directory

  Building C object CMakeFiles/cmTC_5d15a.dir/testCCompiler.c.o

  /usr/bin/cc -o CMakeFiles/cmTC_5d15a.dir/testCCompiler.c.o -c

  Linking C executable cmTC_5d15a.exe

  /usr/bin/cmake.exe -E cmake_link_script CMakeFiles/cmTC_5d15a.dir/link.txt

  /usr/bin/cc -Wl,--enable-auto-import
  CMakeFiles/cmTC_5d15a.dir/testCCompiler.c.o -o cmTC_5d15a.exe

  make[1]: Leaving directory

  Error running link command: No such file or directory

  make[1]: *** [CMakeFiles/cmTC_5d15a.dir/build.make:98: cmTC_5d15a.exe]
  Error 2

  make: *** [Makefile:126: cmTC_5d15a/fast] Error 2

  CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
  CMakeLists.txt:34 (project)

-- Configuring incomplete, errors occurred!
See also "/cygdrive/c/Users/f.brill/Documents/OpenVX/trunk/packages/v_1_1/build64/CMakeFiles/CMakeOutput.log".
See also "/cygdrive/c/Users/f.brill/Documents/OpenVX/trunk/packages/v_1_1/build64/CMakeFiles/CMakeError.log".

Attachment: cygcheck.out
Description: cygcheck.out

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]