This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Trouble installing to UNC path and/or mapped network drive

Andreas Wettergren writes:
> I’m running this as a network user that has full read & write access
> to the target directory and subdirectories.  This user is also a
> member of the local administrator group.
> I’ve tried to run the setup to an empty network path (no prior cygwin
> files, just an empty directory) as well, with identical results.
> Nothing gets written to this directory.

I think the problem is either the local administrator group (sometimes
local administrators are expressedly forbidden to do anything on the
network) or your network user cannot change the DACL on the network
share (another common setup in large organizations).

> I’ve also tried to run the install to a local drive on my computer.
> This works as expected, no problems.

You could try to move / copy that installation to the network share,

> Finally, this sort of install routine has apparently worked in the
> past, my colleague tells me this is the way he has updated our Cygwin
> environment before.  It’s possible he did something slightly
> differently to what I have done this time though.

Or meanwhile some new security policy got installed that throws a
spanner in the works.  If your colleague is still able to update
Cygwin, you'll know it's some sort of access right you're missing and
can work it out from there.

+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Samples for the Waldorf Blofeld:

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]