This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Extreme Slowness of cygwin commands [SOLVED?]

On 5/27/2016 4:13 PM, Ben Altman wrote:
On 5/27/2016 3:58 PM, wrote:
As I said the slowdown was intermittant, Rapport had been running at
least a week or so before the slowdown started which didn't affect for
example cmd or power shell only cygwin that I noticed.

But when I stopped Rapport the slowdown (15+ second process
activation) disappeared instantly.

Needs more investigation but maybe this will help someone else, if I
can save just one child...

I understand and I am not disagreeing with your observations, but in my case, and I failed to mention that I have had Rapport installed for years now, I have not experienced that behavior as you have. Though, I am planning on putting the configuration file of my script back next week to see if that was what caused the behavior on my system. I will try killing Rapport and see if that affects the situation now that you have mentioned it.

This comes a while later but I was wrong and you were right.

I had thought since I had Rapport working with cygwin for so long without issue that it couldn't be the source of the problem with regards to my situation. With the update I did in cygwin something clearly had changed causing a conflict. It took a while but I (finally) uninstalled Rapport Trusteer yesterday and the problem was solved. In the meanwhile I had gone so far as to install Windows versions of the GNU utilities to try my script without cygwin but I had to use cygwin's sort because I couldn't work out how to use it under Windows with a different locale and it conflicted with join with the case insensitive option unlike under cygwin where I could just do "LANG=en_EN sort -uf". I discovered I could use cygwin's sort but if I used it's join while Rapport was running my system was messed up afterwards. There were other triggers as well, but now I am back to a normal system so thank you very much for that advise despite the fact that I ignored it for so long.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]