This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: pure-ftpd fatal error in forked process - fork: can't reserve memory for parent Cygwin x86 Operating Systems

On 15/11/2016 08:33, OwN-3m-All wrote:

Has anyone else run into this issue when trying to get pure-ftpd to work?

      9 [main] pure-ftpd 3032 C:\OGP\usr\sbin\pure-ftpd.exe: *** fatal
error in forked process - fork: can't reserve memory for parent stack
0x1B0000 - 0x3B0000, (child has 0x140000 - 0x340000), Win32 error 487
   1022 [main] pure-ftpd 3032 cygwin_exception::open_stackdumpfile:
Dumping stack trace to pure-ftpd.exe.stackdump
      9 [main] pure-ftpd 2936 fork: child -1 - forked process 3032
died unexpectedly, retry 0, exit code 0x100, errno 11

Full stack trace from log:

Stack trace:
Frame     Function  Args
0033F9F0  7744D2E9 (7FFD9000, 77A16100, 00000000, 00000000)
0033FA30  778B1603 (00AD1000, 7FFD9000, FFFFFFFF, 77917B2E)
0033FA48  778B15D6 (00AD1000, 7FFD9000, 00000000, 00000000)
End of stack trace

I get the reserve memory error when a FTP connection to pure-ftpd is
opened.  pure-ftpd immediately crashes with the above error and the
FTP connection is never established.  I have installed pure-ftpd the
same way on a Windows Server 2008 SP2 x86 instance and a Windows 7 x86
instance.  I run into the same error on each, and each machine has
plenty of RAM available.  Other packages aren't doing this.  It
happens with the built-in anonymous user along with any new users that
eventually are added in /etc/pureftpd.passwd

Setup.exe version 2.876 (32 bit)
pure-ftpd version installed is 1.0.43-1

How are you running pure-ftpd ?
Do you have problem with normal users ?

It may be a problem of authorization to change user owner for the process.

Anyone have any clue what the issue is?  There is no log entry in
/var/log and I see pure-ftpd.exe running as a process... it just
crashes every time a connection is opened.


Please attach the cygcheck.out.

PS:  I can not follow up the matter in detail until next week.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]