This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: too many environment variables on self-compiled xar archiver

Hello Brian,

        Appreciated the reply, tried to search "!C:" on registry or
searching for "!C:" in all files (*.*) content on c:\cygwin or using
tools like rapidee (to edit env variables), and the result is i could
not found it!.
Looks like it's being added by either the bash shell? itself or
something else?. The only i could found is "%{!S:%{!c:%e-c or -S
required for Ada}}" inside c++.exe, cpp.exe, g++.exe, gcc.exe.

Btw my environment is latest cygwin x86, windows 10 x64 creator
update, visual studio 2015 and & 2017 installed, gcc and g++ mingw x86
and x64 installed. Latest cygwin snapshot.


On Wed, May 24, 2017 at 9:53 AM, Brian Inglis
<> wrote:
> On 2017-05-23 16:30, Michael Stellar wrote:
>> I am getting the following when running my self-compiled xar 1.6.1 archiver
>> gdb xar
>> Starting program: /usr/local/bin/xar
>> [New Thread 12044.0x1f54]
>> [New Thread 12044.0xfc8]
>> [New Thread 12044.0x2dcc]
>> [New Thread 12044.0x2cd8]
>> [New Thread 12044.0x2d58]
>>       1 [main] xar 12044 C:\cygwin\usr\local\bin\xar.exe: *** fatal
>> error - internal error reading the windows environment - too many
>> environment variables?
>>     739 [main] xar 12044 cygwin_exception::open_stackdumpfile: Dumping
>> stack trace to xar.exe.stackdump
>> [Thread 12044.0x2dcc exited with code 256]
>> [Thread 12044.0xfc8 exited with code 256]
>> [Thread 12044.0x2cd8 exited with code 256]
>> [Inferior 1 (process 12044) exited with code 0400]
>> My env variables is here , i have tried
>> to unset some of the long variables but the error still persist.
> Did you notice this entry and does anyone know where this comes from?
>         !C:=C:\cygwin\bin
> Another poster found a problem with non-ascii accented initial letters
> in the environment variable name - perhaps this is the same problem?
> If Cygwin environment setup has a problem with an environment variable
> name or contents, it should either ignore it, copy it, or convert it to
> Cygwin format, but it seems to be stumbling, when it should just be
> ignoring it and skipping to the next variable.
> Try removing that environment variable, either from the Control Panel,
> or directly in regedit if necessary.
> --
> Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada
> --
> Problem reports:
> FAQ:         
> Documentation:
> Unsubscribe info:

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]