This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Compiled programs fail to run from Cygwin Terminal, but work from windows cmd


Having installed Cygwin with no errors I could see, I went on to
compile and run "hello world" - as you do. I could make it go from a
windows command prompt after modifying the system path to include
cygwin\bin, so - so far so good.

>From the cygwin terminal, however, the same executable refuses to play
ball. No text is shown; the command prompt returns instantly.

I have tried looking in the mailing list archive, and the answer may
well be there (in which case I apologise). But the searches I have
tried either returned nothing, or an incredible amount of information
that was not apparently relevant to my problem.

Maybe the attached strace output tells somebody something; to me its
only helpful thing is that it shows that the cygwin1.dll is found and
loaded, which eliminates the most likely potential problem that I
could see. Dependency Walker only mutters about 64-bit and 32-bit
libraries being mixed, but as the program runs under the Windows
command prompt, I am discounting that as a reason for the failure.

All the standard pre-compiled utilities I tried run as expected from
the cygwin terminal.

I'd be very grateful for a pointer!
Wouter van Doorn

Attachment: cygcheck.out
Description: Binary data

Attachment: hello.strace.out
Description: Binary data

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]